Skip to content

Commit

Permalink
dev-util/ccache: version bump
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Aug 16, 2015
1 parent e34730b commit 7ff576f
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/ccache/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST ccache-3.1.10.tar.xz 240932 SHA256 88439f43d3b426ab435afdf69a808511bada4de3
DIST ccache-3.1.9.tar.xz 238988 SHA256 4981fdf3ad851de400d94083a0d03f115ce9ce8062c3fd7a291630294b0006c4 SHA512 b73f5816bb87c2d94200473510ea42a304c5a2c5e5f14720c513574ce3eb983423c5849a786a89df70cbb09852d9ec2761ad37a820a767d7350e1a3243148ac0 WHIRLPOOL 61ef671aae68516ecfaee88a50b8f442968a7ab24595fd7dfc652ab27de80834d90510c62cfcc75dd88e1f3832989633f518ebe5984149c16d5ab9848cff05fc
DIST ccache-3.2.1.tar.xz 297868 SHA256 872af34e1d2cef18694001d29db7f167d644e7602ca32cd6c74b28d81458bd9d SHA512 ef0e56f2d1775fb0f401f48cca2a65eb415f4e2ccf0bcfd769045a9c08c3c2977db4edea12e06629f4cb5406cde23cd3ee0910e2e4d5eff9376227fa23c78a7a WHIRLPOOL f3d07cf142258d588a1c6cb9ba77d31d7b568cd18ae131ed3526595c809352b0fa30ae61b0bfcbfde3ea8d959c545119662c25af0cd03c97517be361315e1ffe
DIST ccache-3.2.2.tar.xz 300808 SHA256 4f0d99699f24d198494addca0f41a93b0150cdfd01491f15a5d7eb02c7c2a0ca SHA512 fc438f3b00baa41076eee3e5783ea53a208eb348343e587c6f729f7e98462cd20c720fe323fe08f271bc14dae48f7828cef769882f028f3772992989b87b075d WHIRLPOOL 095a125e869910644622b98b7720a01ccc235fbeb8c84ec52017fe52f82fe7b8122584c3e5fa4d39c1344e9c062517a1edb46c3e64fe649e845ed5c1fb455c5a
DIST ccache-3.2.3.tar.xz 301728 SHA256 ec0414fc435982ece8b8fca062f5836ff32c5d5148abd7f80768614ed776600e SHA512 27da2032fd8936253e29f0410fc2f8085967de78ebe300bd1efecf78c67ed5e060e543df96bb29bc1bea75ec4d5e108f89d58dc6d9573bf6fcc8384d00b951dd WHIRLPOOL 721e9e8dab552c40bfd77df3225e33d49553b2bee5ec990dc6f33ce8bdd9009f4f35b75d08d04ce51ee36e0772a5b403c4d8629627dd6d488b717e23b3d3657c
68 changes: 68 additions & 0 deletions dev-util/ccache/ccache-3.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils readme.gentoo

DESCRIPTION="fast compiler cache"
HOMEPAGE="http://ccache.samba.org/"
SRC_URI="http://samba.org/ftp/ccache/${P}.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE=""

DEPEND="app-arch/xz-utils
sys-libs/zlib"
RDEPEND="${DEPEND}
sys-apps/gentoo-functions"

src_prepare() {
# make sure we always use system zlib
rm -rf zlib || die
epatch "${FILESDIR}"/${PN}-3.1.10-size-on-disk.patch #456178
sed \
-e "/^EPREFIX=/s:'':'${EPREFIX}':" \
"${FILESDIR}"/ccache-config-3 > ccache-config || die
}

src_install() {
DOCS=( AUTHORS.txt MANUAL.txt NEWS.txt README.txt )
default

dobin ccache-config

DOC_CONTENTS="
To use ccache with **non-Portage** C compiling, add
${EPREFIX}/usr/lib/ccache/bin to the beginning of your path, before ${EPREFIX}usr/bin.
Portage 2.0.46-r11+ will automatically take advantage of ccache with
no additional steps. If this is your first install of ccache, type
something like this to set a maximum cache size of 2GB:\\n
# ccache -M 2G\\n
If you are upgrading from an older version than 3.x you should clear all of your caches like so:\\n
# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C\\n
ccache now supports sys-devel/clang and dev-lang/icc, too!"

readme.gentoo_create_doc
}

pkg_prerm() {
if [[ -z ${REPLACED_BY_VERSION} ]] ; then
"${EROOT}"/usr/bin/ccache-config --remove-links
"${EROOT}"/usr/bin/ccache-config --remove-links ${CHOST}
fi
}

pkg_postinst() {
"${EROOT}"/usr/bin/ccache-config --install-links
"${EROOT}"/usr/bin/ccache-config --install-links ${CHOST}

# nuke broken symlinks from previous versions that shouldn't exist
rm -f "${EROOT}"/usr/lib/ccache/bin/${CHOST}-cc || die
rm -rf "${EROOT}"/usr/lib/ccache.backup || die

readme.gentoo_print_elog
}

0 comments on commit 7ff576f

Please sign in to comment.