Skip to content

Commit

Permalink
app-arch/unp: respect LINGUAS variable
Browse files Browse the repository at this point in the history
Also port to EAPI 6, change upstream URL to https.

Package-Manager: portage-2.3.2
  • Loading branch information
hannob committed Oct 15, 2016
1 parent 7f283e0 commit 8011cac
Showing 1 changed file with 45 additions and 0 deletions.
45 changes: 45 additions & 0 deletions app-arch/unp/unp-2.0_pre7_p1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils bash-completion-r1

DESCRIPTION="Script for unpacking various file formats"
HOMEPAGE="https://packages.qa.debian.org/u/unp.html"
TEMP_PV="${PV/_pre/$'\x7e'pre}"
MY_PV="${TEMP_PV/_p/+nmu}"
SRC_URI="mirror://debian/pool/main/u/unp/${PN}_${MY_PV}.tar.bz2"
S="${WORKDIR}/${PN}-${MY_PV}"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="nls"

DEPEND="nls? ( sys-devel/gettext )"

RDEPEND="${DEPEND}
dev-lang/perl"

PATCHES=( "${FILESDIR}/${P}-remove-deprecated-have.diff" )

src_compile() {
if use nls; then
strip-linguas -i .
emake -C po MOFILES="${LINGUAS/ /.po }.po"
fi
}

src_install() {
dobin unp || die "dobin failed"
dosym /usr/bin/unp /usr/bin/ucat
doman debian/unp.1 || die "doman failed"
dodoc debian/changelog debian/README.Debian
dobashcomp bash_completion.d/unp

if use nls; then
emake -C po MOFILES="${LINGUAS/ /.mo }.mo" DESTDIR="${D}" install
fi
}

0 comments on commit 8011cac

Please sign in to comment.