Skip to content

Commit

Permalink
games-misc/ponysay: New package to supersede one from aidstu-overlay
Browse files Browse the repository at this point in the history
zsh-completion is broken in the latest release but I have included it
anyway.

Package-Manager: portage-2.3.3
  • Loading branch information
chewi committed Dec 18, 2016
1 parent ab146b0 commit 803ddbc
Show file tree
Hide file tree
Showing 3 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-misc/ponysay/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST ponysay-3.0.2.tar.gz 2110382 SHA256 69e98a7966353de2f232cbdaccd8ef7dbc5d0bcede9bf7280a676793e8625b0d SHA512 47d5c584b3b8c233567eff534b5109548c92075f69776703bc303929ba4278f67fd599987ef4a098aa871c2af0efd89186f96fa28565e73b4672abeb0c23fa45 WHIRLPOOL 9ba79521c95948498cffb3fa8c921dfeab9188d215ddd57c777517e54453979ea4f40ec1faea894a8a967fce78fe08767bf915d7bdeca4807a337099e7d8c265
12 changes: 12 additions & 0 deletions games-misc/ponysay/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Games Project</name>
</maintainer>
<use>
<flag name="fish-completion">Enable fish completion support</flag>
<flag name="non-free">Install non-free ponies (i.e. from the MLP franchise)</flag>
</use>
</pkgmetadata>
60 changes: 60 additions & 0 deletions games-misc/ponysay/ponysay-3.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=6

PYTHON_COMPAT=( python3_{4,5} )
inherit bash-completion-r1 python-single-r1

DESCRIPTION="cowsay reimplemention for ponies"
HOMEPAGE="https://github.com/erkin/ponysay"
SRC_URI="https://github.com/erkin/ponysay/archive/3.0.2.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc +non-free bash-completion fish-completion zsh-completion"

DEPEND="${PYTHON_DEPS}
doc? ( sys-apps/texinfo )"

RDEPEND="${PYTHON_DEPS}
fish-completion? ( app-shells/fish )
zsh-completion? ( app-shells/zsh )"

setup_py() {
"${PYTHON}" setup.py \
--prefix="${EPREFIX}"/usr \
--everything \
--without-info-compression \
--without-man-compression \
--without-pdf-compression \
--without-shared-cache \
--freedom=$(usex non-free no yes) \
$(use_with fish-completion) \
$(use_with zsh-completion) \
$(use_with doc info) \
$(use_with doc pdf "${EPREFIX}"/usr/share/doc/${PF}) \
"${@}" || die
}

src_compile() {
setup_py \
$(use_with bash-completion) \
build
}

src_install() {
setup_py \
--without-bash-completion \
--destdir="${D}" \
prebuilt

python_fix_shebang "${ED}"/usr/bin/${PN}

rm -rv "${ED}"/usr/share/licenses || die
dodoc CHANGELOG CONTRIBUTING CREDITS README.md

use bash-completion &&
newbashcomp completion/bash-completion.${PN}.install ${PN}
}

0 comments on commit 803ddbc

Please sign in to comment.