Skip to content

Commit

Permalink
dev-php/PHP_CodeSniffer: bump to v3.6.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Oct 15, 2021
1 parent f6490b4 commit 8040f44
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/PHP_CodeSniffer/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST PHP_CodeSniffer-3.5.4.tgz 697668 BLAKE2B f5915bcb73c0db0d8dcab3eda5ab647268
DIST PHP_CodeSniffer-3.5.6.tgz 706080 BLAKE2B 1d9d097e7c60f520973a0dff16e6b31c9e259599ded3f58ac6dda2f10419969b03c18d1ce7c38f19a0f3474b0d5cf4afc5abb889f820da0d5d9e8f0574a0a354 SHA512 392c162cc8cb8d8fe455990d7f358cc59f486d8083387dc3bf60af6ca7aa0e75b72ed337f624b08948d8060cc96bd2d03373b7508fb9179da6a4e6b83adf06a7
DIST PHP_CodeSniffer-3.5.8.tgz 716472 BLAKE2B e56efedc07a9db63eb2f135d9fef69bf055cef09c23dd9cd1e0efeed865d559b428e9aec06393b1ec1f58d32add92b2773c3d9ce33377f2441de0145560045a8 SHA512 69ef3d86520f541f492c955bd8158664c78aac6ecd4550f2b996f59d882d91f1bec81da9bbd106edc35c4f1a4c260ef2d9a56ec257fc0b4044047b902403065e
DIST PHP_CodeSniffer-3.6.0.tgz 762998 BLAKE2B f83626a2a64dbb5c7ae2545368f1efdf74d87630720efe7466d9adfd6591cbcc95f2b74a17f54a935377519c6d909ba17f4056fff6d8f3870cefe782f32675dd SHA512 09c98ac460c6dc70637d2f4d81a1e46bdf742ee14d0b56032e8dbcaf7a0ff03f3fdb1abdf8144f664a33298cf397c732ba62027bcee41f1f4f740d12fa29f6a8
DIST PHP_CodeSniffer-3.6.1.tgz 773181 BLAKE2B a85a0008fe9788bb48723fdd6a62d646a70bb342099693299def9320ca12971c48d8bc698e001f3249e8bb94963735c57529fe2d3101d53ded5ffd0946e07d4f SHA512 4992a460494cf58e5731e10df216204842168465731c0d002b7913fbaa85370f01077f70c96b4390158fbcf52ee021650ab6f13609ea3133370b89f34c73343c
55 changes: 55 additions & 0 deletions dev-php/PHP_CodeSniffer/PHP_CodeSniffer-3.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DESCRIPTION="Detect violations of PHP code standards"
HOMEPAGE="https://github.com/squizlabs/PHP_CodeSniffer"

# The test suite isn't part of the Github tarball at the moment. Keep an
# eye on https://github.com/squizlabs/PHP_CodeSniffer/issues/548
SRC_URI="http://download.pear.php.net/package/${P}.tgz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="dev-lang/php:*[cli(-),tokenizer(-),xmlwriter(-)]"
DEPEND="test? (
${RDEPEND}
<dev-php/phpunit-6
)"

DOCS=( CONTRIBUTING.md README.md )

src_prepare() {
sed -i "s~@data_dir@~${EPREFIX}/usr/share/php/data~" src/Config.php || die
default
}

src_test() {
# The test suite will fail if date.timezone isn't set in php.ini.
phpunit -d date.timezone=UTC tests/AllTests.php \
|| die "test suite failed"
}

src_install() {
local MY_PN="PHP/CodeSniffer" script
# The PEAR eclass would install everything into the wrong location.
insinto "/usr/share/php/${MY_PN}"
doins -r src autoload.php

insinto "/usr/share/php/data/${MY_PN}"
doins CodeSniffer.conf.dist
# These load code via relative paths, so they have to be symlinked
# and not dobin'd.
exeinto "/usr/share/php/${MY_PN}/bin"
for script in phpcbf phpcs; do
doexe "bin/${script}"
dosym "../share/php/${MY_PN}/bin/${script}" "/usr/bin/${script}"
done

einstalldocs
}

0 comments on commit 8040f44

Please sign in to comment.