Skip to content

Commit

Permalink
media-gfx/fontforge: fix build with >=media-libs/freetype-2.10.3
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/753788
Package-Manager: Portage-3.0.8, Repoman-3.0.2
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Nov 16, 2020
1 parent 2a8dd18 commit 8115713
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 0 deletions.
60 changes: 60 additions & 0 deletions media-gfx/fontforge/files/fontforge-20200314-freetype-2.10.3.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
https://bugs.gentoo.org/753788
https://github.com/fontforge/fontforge/commit/7837530190a3b666109ba4eb9b3b76f09799057c
----
From 7837530190a3b666109ba4eb9b3b76f09799057c Mon Sep 17 00:00:00 2001
From: Jeremy Tan <[email protected]>
Date: Tue, 3 Nov 2020 21:27:26 +1100
Subject: [PATCH] Fix FreeType debugger compilation with FreeType >= 2.10.3

Fixes #4477
---
fontforge/fffreetype.h | 4 +++-
fontforgeexe/cvdebug.c | 4 +++-
fontforgeexe/cvdgloss.c | 4 +++-
3 files changed, 9 insertions(+), 3 deletions(-)

diff --git a/fontforge/fffreetype.h b/fontforge/fffreetype.h
index 7757b7bf3b..11070fc916 100644
--- a/fontforge/fffreetype.h
+++ b/fontforge/fffreetype.h
@@ -39,7 +39,9 @@
#endif

#if defined(FREETYPE_HAS_DEBUGGER)
-# include <internal/internal.h>
+#if FREETYPE_MAJOR == 2 && (FREETYPE_MINOR < 10 || (FREETYPE_MINOR == 10 && FREETYPE_PATCH < 3))
+# include <internal/internal.h>
+# endif
# include <ttdriver.h>
# include <ttinterp.h>
# include <ttobjs.h>
diff --git a/fontforgeexe/cvdebug.c b/fontforgeexe/cvdebug.c
index 9fb7db6112..a891902a06 100644
--- a/fontforgeexe/cvdebug.c
+++ b/fontforgeexe/cvdebug.c
@@ -59,7 +59,9 @@ void CVDebugPointPopup(CharView *cv) {
#include <ft2build.h>
#include FT_FREETYPE_H

-#include <internal/internal.h>
+#if FREETYPE_MAJOR == 2 && (FREETYPE_MINOR < 10 || (FREETYPE_MINOR == 10 && FREETYPE_PATCH < 3))
+# include <internal/internal.h>
+#endif
#include <ttinterp.h>

# define PPEMX(exc) ((exc)->size->root.metrics.x_ppem)
diff --git a/fontforgeexe/cvdgloss.c b/fontforgeexe/cvdgloss.c
index 33cc5c71e1..c1ad97790b 100644
--- a/fontforgeexe/cvdgloss.c
+++ b/fontforgeexe/cvdgloss.c
@@ -42,7 +42,9 @@ extern GBox _ggadget_Default_Box;
#include <ft2build.h>
#include FT_FREETYPE_H

-#include <internal/internal.h>
+#if FREETYPE_MAJOR == 2 && (FREETYPE_MINOR < 10 || (FREETYPE_MINOR == 10 && FREETYPE_PATCH < 3))
+# include <internal/internal.h>
+#endif
#include <ttinterp.h>

#define PPEMX(exc) ((exc)->size->root.metrics.x_ppem)
1 change: 1 addition & 0 deletions media-gfx/fontforge/fontforge-20200314.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -58,6 +58,7 @@ PATCHES=(
"${FILESDIR}"/20200314-big-endian.patch
"${FILESDIR}"/fontforge-doc-no-warn-error.patch
"${FILESDIR}"/20200314-MacServiceReadFDs.patch
"${FILESDIR}"/${P}-freetype-2.10.3.patch
)

pkg_setup() {
Expand Down

0 comments on commit 8115713

Please sign in to comment.