Skip to content

Commit

Permalink
app-forensics/galleta: Port to EAPI 6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
SoapGentoo committed Dec 29, 2017
1 parent 5307dec commit 815909f
Show file tree
Hide file tree
Showing 3 changed files with 37 additions and 7 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/galleta.c
+++ b/galleta.c
@@ -35,6 +35,8 @@
#include <stdio.h>
#include <time.h>
#include <math.h>
+#include <stdlib.h>
+#include <string.h>

#define STRSIZE 1000

Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,6 @@
-all: install
+LDLIBS += -lm

-install: galleta.c
- gcc -o galleta galleta.c -lm -lc;cp galleta ../bin
+all: galleta

installwin: galleta.c
gcc -DCYGWIN -o galleta.exe galleta.c -lm -lc;cp galleta.exe ../bin
21 changes: 14 additions & 7 deletions app-forensics/galleta/galleta-20040505_p1.ebuild
Original file line number Diff line number Diff line change
@@ -1,25 +1,32 @@
# Copyright 1999-2012 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs

MY_P=${PN}_${PV/_p/_}

DESCRIPTION="IE Cookie Parser"
HOMEPAGE="https://sourceforge.net/projects/odessa/"
SRC_URI="mirror://sourceforge/odessa/${MY_P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE=""

S=${WORKDIR}/${MY_P}
S=${WORKDIR}/${MY_P}/src
PATCHES=(
"${FILESDIR}"/${P}-fix-build-system.patch
"${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
)

src_compile() {
cd src
$(tc-getCC) ${CFLAGS} ${LDFLAGS} -o galleta galleta.c -lm -lc || die "failed to compile"
src_configure() {
tc-export CC
}

src_install() {
dodoc Readme.txt
dobin src/galleta
dobin ${PN}
dodoc ../{CHANGES,Readme.txt}
}

0 comments on commit 815909f

Please sign in to comment.