Skip to content

Commit

Permalink
app-shells/tcsh: add patch to fix USE=-nls, bug #689904
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/689904
Signed-off-by: Fabian Groffen <[email protected]>
Package-Manager: Portage-2.3.66, Repoman-2.3.11
  • Loading branch information
grobian committed Jul 16, 2019
1 parent 0a7ab03 commit 82219cb
Show file tree
Hide file tree
Showing 2 changed files with 18 additions and 0 deletions.
17 changes: 17 additions & 0 deletions app-shells/tcsh/files/tcsh-6.21.00-no-nls.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
GetCmdChar: fix compilation with --disable-nls

Bug: https://bugs.gentoo.org/689904

--- a/ed.inputl.c
+++ b/ed.inputl.c
@@ -669,8 +669,8 @@
{
#ifndef WINNT_NATIVE // We use more than 256 for various extended keys
- wint_t c = ch & CHAR;
+ eChar c = ch & CHAR;
#else
- wint_t c = ch;
+ eChar c = ch;
#endif
return c < NT_NUM_KEYS ? CurrentKeyMap[c] : F_INSERT;
}
1 change: 1 addition & 0 deletions app-shells/tcsh/tcsh-6.21.00.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -32,6 +32,7 @@ CONFDIR=${WORKDIR}/tcsh-gentoo-patches-r${CONFVER}
PATCHES=(
"${FILESDIR}"/${PN}-6.20.00-debian-dircolors.patch # bug #120792
"${FILESDIR}"/${PN}-6.18.01-aix.patch
"${FILESDIR}"/${PN}-6.21.00-no-nls.patch
)

src_prepare() {
Expand Down

0 comments on commit 82219cb

Please sign in to comment.