forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-analyzer/xprobe: Fix compiling with sys-devel/clang
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Closes: https://bugs.gentoo.org/740654 Signed-off-by: Jeroen Roovers <[email protected]>
- Loading branch information
Jeroen Roovers
committed
Sep 6, 2020
1 parent
9bd500a
commit 8345db6
Showing
2 changed files
with
47 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- a/src/defines.h.in | ||
+++ b/src/defines.h.in | ||
@@ -24,7 +24,7 @@ | ||
|
||
#define VERSION "@VERSION@" | ||
#define BANNER \ | ||
-"\nXprobe2 v."VERSION\ | ||
+"\nXprobe2 v." VERSION \ | ||
" Copyright (c) 2002-2005 [email protected], [email protected], [email protected]"\ | ||
"\n" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit toolchain-funcs | ||
|
||
MY_P=${PN}2-${PV} | ||
|
||
DESCRIPTION="Active OS fingerprinting tool - this is Xprobe2" | ||
HOMEPAGE="http://sys-security.com/blog/xprobe2" | ||
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~sparc ~x86" | ||
|
||
DEPEND="net-libs/libpcap" | ||
RDEPEND="${DEPEND}" | ||
PATCHES=( | ||
"${FILESDIR}"/${P}-gcc43.patch | ||
"${FILESDIR}"/${P}-cxx11.patch | ||
) | ||
S=${WORKDIR}/${MY_P} | ||
|
||
src_prepare() { | ||
default | ||
sed -i -e 's:strip:true:' src/Makefile.in || die | ||
sed -i -e 's:ar cr:$(AR) cr:g' $(find -name '*Makefile*') || die | ||
|
||
tc-export AR | ||
} | ||
|
||
src_install() { | ||
default | ||
dodoc AUTHORS CHANGELOG CREDITS README TODO docs/*.{txt,pdf} | ||
} |