Skip to content

Commit

Permalink
x11-plugins/pidgin-musictracker: Port to EAPI 7
Browse files Browse the repository at this point in the history
* Fix build with gcc-10

Closes: https://bugs.gentoo.org/717424
Signed-off-by: Jakov Smolic <[email protected]>
Signed-off-by: Ben Kohler <[email protected]>
  • Loading branch information
Jakov Smolic authored and benkohler committed Feb 9, 2021
1 parent 4ac9221 commit 8372206
Show file tree
Hide file tree
Showing 2 changed files with 22 additions and 7 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
https://bugs.gentoo.org/717424
--- a/src/utils.h
+++ b/src/utils.h
@@ -21,7 +21,7 @@ pcre* regex(const char* pattern, int options);
int capture(pcre* re, const char *text, int len, ...);

#ifndef WIN32
-DBusGConnection *connection;
+extern DBusGConnection *connection;
gboolean dbus_g_init_connection(void);
gboolean dbus_g_running(const char *name);
#endif
17 changes: 10 additions & 7 deletions x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.22.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit autotools

Expand All @@ -14,15 +14,18 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="debug"

DEPEND=">=net-im/pidgin-2.0.0[gtk]
>=dev-libs/dbus-glib-0.73
DEPEND="
dev-libs/dbus-glib
dev-libs/libpcre
>=sys-devel/gettext-0.17"
net-im/pidgin[gtk]"
RDEPEND="${DEPEND}"
BDEPEND="sys-devel/gettext"

PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )

src_prepare() {
default
sed -i -e "s/DOMAIN/PACKAGE/g" po/Makefile.in.in || die "sed failed"
sed -i -e "s/DOMAIN/PACKAGE/g" po/Makefile.in.in || die
eautoreconf
}

Expand All @@ -34,5 +37,5 @@ src_configure() {

src_install() {
default
find "${D}" -name "*.la" -delete || die "error cleaning la file."
find "${ED}" -name '*.la' -delete || die
}

0 comments on commit 8372206

Please sign in to comment.