Skip to content

Commit

Permalink
dev-cpp/catch: Bump to 1.9.7
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Aug 12, 2017
1 parent f557e0c commit 83f7a33
Show file tree
Hide file tree
Showing 2 changed files with 35 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/catch/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST Catch-1.9.4.tar.gz 363097 SHA256 d67d2ee26ec9f72618dd9b28a9d1b7ba3c6368bc846ecfeda05a1e5d1b8b9b20 SHA512 78d43719e87f5d27132178c5f139b72e6093dd1029eb742bfb48e32b618079e156837fb25d4cbe0fd5044535a5a65ad90510cff8ae93f2695c7bb3fc5cb2a5ec WHIRLPOOL 80b4c36172e62ea12fc4acee096a84cd00b1a290dc2a7a9e9a8e2ff2485e39a619e33f2aee853daa7773d3c877f55788b2d0f86e44542c6f8c0b6027edaf0585
DIST Catch-1.9.6.tar.gz 367108 SHA256 d1fc9f0018fe55a1b74168d5c37a2cf6580a902dab9b646050373e70090b2c61 SHA512 6d4989518935d60d2274361ad64649be9241e4de435d34cb04ac8ee2f7b25deb33c8919acaa3cd1c0d68c7822f15d74d0f19115ab72bb93d2cf8b3a0205e44c6 WHIRLPOOL 7c1d3a779a144a9d51a3b512bc5295d68e98c1d0d6fea600a586d2bcafc2141c57beacbb4ab5d58376e096d27681fd7a5f416c5f78cfc6635634ba00707cff06
DIST Catch-1.9.7.tar.gz 371816 SHA256 751090d755072777c5bb98de6ead1f7919ea239d4b77bb028fb7b06624ec0d7a SHA512 573d324b3e0ffe1026bdd10410a9299eff6d3e0a316b2b84c687dc993fb33570620e26107667ce8b59ab66844cfbc39526ed6ba4e9dd1ba529c6b21ebd274b63 WHIRLPOOL 1d3bcf6b2a3d8af6fba7ded0e92d7381857360a4bbf2dd689474408c52612f874da35579ad0adaf13679e1d8aaddee101274cd29070a5a51d58e7d52b76473f2
34 changes: 34 additions & 0 deletions dev-cpp/catch/catch-1.9.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

DESCRIPTION="Modern C++ header-only framework for unit-tests"
HOMEPAGE="https://github.com/philsquared/Catch"
SRC_URI="https://github.com/philsquared/Catch/archive/v${PV}.tar.gz -> ${P^}.tar.gz"

LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

S=${WORKDIR}/${P^}

# CMake is only used to build & run tests, so override phases
src_configure() { :; }
src_compile() { :; }

src_test() {
cmake-utils_src_configure
cmake-utils_src_compile
cmake-utils_src_test
}

src_install() {
# same location as used in fedora
insinto /usr/include/catch
doins -r include/.
dodoc -r docs/.
}

0 comments on commit 83f7a33

Please sign in to comment.