Skip to content

Commit

Permalink
dev-util/colorgcc: Port to EAPI 7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Feb 9, 2020
1 parent 3fba91b commit 869fdaa
Show file tree
Hide file tree
Showing 5 changed files with 24 additions and 30 deletions.
30 changes: 12 additions & 18 deletions dev-util/colorgcc/colorgcc-1.3.2-r7.ebuild
Original file line number Diff line number Diff line change
@@ -1,18 +1,15 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit eutils
EAPI=7

DESCRIPTION="Perl script to colorise the gcc output."
HOMEPAGE="http://schlueters.de/colorgcc.html"
SRC_URI="mirror://gentoo/${P}.tar.gz"

SLOT="0"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 hppa ~mips ppc sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE=""

DEPEND="dev-lang/perl"
RDEPEND="${DEPEND}"
Expand All @@ -24,24 +21,21 @@ PATCHES=(
"${FILESDIR}"/${P}-nohang.patch
)

src_prepare() {
epatch "${PATCHES[@]}"
}

src_install() {
dobin "${PN}"
dodir "/etc/${PN}" "/usr/lib/${PN}/bin"
insinto "/etc/${PN}"
doins "${PN}rc"
dobin ${PN}

insinto /etc/${PN}
doins ${PN}rc

einfo "Scanning for compiler front-ends"
into "/usr/lib/${PN}/bin"
local COMPILERS=( gcc cc c++ g++ ${CHOST}-gcc ${CHOST}-c++ ${CHOST}-g++ )
dodir /usr/lib/${PN}/bin
local c COMPILERS=( gcc cc c++ g++ ${CHOST}-gcc ${CHOST}-c++ ${CHOST}-g++ )
for c in "${COMPILERS[@]}"; do
[[ -n "$(type -p ${c})" ]] && \
dosym "/usr/bin/${PN}" "/usr/lib/${PN}/bin/${c}"
dosym ../../../bin/${PN} /usr/lib/${PN}/bin/${c}
done

dodoc CREDITS ChangeLog
einstalldocs
}

pkg_postinst() {
Expand Down
12 changes: 6 additions & 6 deletions dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-one.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- colorgcc.orig 1999-04-29 10:16:08.000000000 -0700
+++ colorgcc 2003-04-11 16:38:52.000000000 -0700
--- a/colorgcc
+++ b/colorgcc
@@ -88,16 +88,16 @@
#
# 1.0.0 Initial Version
Expand Down Expand Up @@ -188,8 +188,8 @@
+ waitpid($compiler_pid, 0);
+ exit ($? >> 8);
+}
--- colorgccrc.orig 1999-04-29 10:16:08.000000000 -0700
+++ colorgccrc 2003-02-12 17:38:38.000000000 -0800
--- a/colorgccrc
+++ b/colorgccrc
@@ -20,12 +20,14 @@
# For example, srcColor: bold cyan on_yellow
#
Expand Down Expand Up @@ -225,8 +225,8 @@
errorMessageColor: bold red
-
-
--- INSTALL.orig 1999-04-29 10:16:08.000000000 -0700
+++ INSTALL 2003-04-07 17:12:25.000000000 -0700
--- a/INSTALL
+++ b/INSTALL
@@ -27,9 +27,9 @@
When "g++" is invoked, colorgcc is run instead. colorgcc looks at the
program name to figure out which compiler to use.
Expand Down
4 changes: 2 additions & 2 deletions dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-two.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- colorgcc.r9 2003-09-21 12:14:48.000000000 -0700
+++ colorgcc 2003-09-21 13:11:22.000000000 -0700
--- a/colorgcc
+++ b/colorgcc
@@ -95,6 +95,7 @@
use Cwd 'abs_path';

Expand Down
4 changes: 2 additions & 2 deletions dev-util/colorgcc/files/colorgcc-1.3.2-nohang.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- /usr/bin/colorgcc 2010-12-13 00:08:37.000000000 -0200
+++ colorgcc 2011-10-05 15:26:53.000000000 -0300
--- a/colorgcc
+++ b/colorgcc
@@ -221,17 +221,16 @@
# Figure out which compiler to invoke based on our program name.
$0 =~ m%.*/(.*)$%;
Expand Down
4 changes: 2 additions & 2 deletions dev-util/colorgcc/files/colorgcc-1.3.2-note.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- /usr/bin/colorgcc 2009-10-29 20:24:46.717190000 +0100
+++ colorgcc 2009-10-29 20:27:42.614162888 +0100
--- a/colorgcc
+++ b/colorgcc
@@ -102,7 +102,8 @@
$nocolor{"dumb"} = "true";

Expand Down

0 comments on commit 869fdaa

Please sign in to comment.