Skip to content

Commit

Permalink
dev-php/pecl-apcu_bc: Revision bump for EAPI and php 7.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
  • Loading branch information
Brian Evans committed Dec 8, 2016
1 parent 7cfcecf commit 870e702
Showing 1 changed file with 35 additions and 0 deletions.
35 changes: 35 additions & 0 deletions dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PHP_EXT_NAME="bc_apc"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_EXT_EXTRA_ECONF=""
DOCS=( README.md )

USE_PHP="php7-0 php7-1"

inherit php-ext-pecl-r3

KEYWORDS="~amd64 ~x86"

DESCRIPTION="Provides APC backwards compatibility functions via APCu"
LICENSE="PHP-3.01"
SLOT="0"
IUSE=""

DEPEND="dev-php/pecl-apcu:7[php_targets_php7-0?,php_targets_php7-1?]"
RDEPEND="${DEPEND}"

src_install() {
# Rename the apc.so to match the ini file loading requirement
local slot
for slot in $(php_get_slots); do
php_init_slot_env ${slot}
mv "modules/apc.so" "modules/${PHP_EXT_NAME}.so" || die
done
php-ext-pecl-r3_src_install
}

0 comments on commit 870e702

Please sign in to comment.