Skip to content

Commit

Permalink
mate-extra/mate-sensors-applet: version bump to 1.16.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.1
  • Loading branch information
mudler committed Dec 8, 2016
1 parent 2a7316e commit 87368c6
Show file tree
Hide file tree
Showing 2 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions mate-extra/mate-sensors-applet/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mate-sensors-applet-1.12.1.tar.xz 369492 SHA256 94d1eae184d11431a922eabc3210bb192f3686ca75441718ac5ff9e05bd39933 SHA512 2e96708e4e27d545b0ad010dbd04139c5d340be1138236ba1197c2cf16486005905264e381f8dde75ea6c23c29bd1a0dd03afb5726340cad718d06914d4dd994 WHIRLPOOL 5534897f6532fb4d2b8016cd06b2f64bef7b97aca7156062327def9174a9a03e497e2120fb09f0acf36b663256c809db10a30d1edad922a8590e23e32c2e59e6
DIST mate-sensors-applet-1.14.0.tar.xz 389960 SHA256 f825e663d409458cc9e6c399ae78140422e3f5f225aa3bebf2e1837434da1a8f SHA512 8d1afdb491e3a4a72dbee098ff3383a9562ab47da81d68807cb1fe72ee9f2ccad31cbe355268d7641fc213dcabf8a4527f03e04c4d8a166584730e934f006f5f WHIRLPOOL f1af968c8770482d4a11e6954aa12ae57a939997ffc06ae888672107138fe257af5aeeb99599f0ac47b464cad17f8dee9e24c8dec8720f418ac62a6e5e26cde6
DIST mate-sensors-applet-1.16.0.tar.xz 393436 SHA256 878cef0dddc3f77b143e04e5d01f9057fa8a387d1f2bb4ee4f1f5123143ab127 SHA512 7fef6e9ef7ef9d4596e0e58217c600a1a800cc483cede875ed60316dda5a51bc98746b4e2a6d650ada8bb3438ab8fc4f7cc451c552df54191152d66e7a7da34a WHIRLPOOL 71de0235643d225379b9f1d1e4d57db43e23d866fff96689ab7a36614607509d808789e49e606db0a8579a043e91eef18106b4d0470a012d594cf80d28a7aa70
70 changes: 70 additions & 0 deletions mate-extra/mate-sensors-applet/mate-sensors-applet-1.16.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

MATE_LA_PUNT="yes"

inherit mate

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~x86"
fi

DESCRIPTION="MATE panel applet to display readings from hardware sensors"
LICENSE="GPL-2"
SLOT="0"

IUSE="+dbus gtk3 hddtemp libnotify lm_sensors video_cards_fglrx video_cards_nvidia"

COMMON_DEPEND=">=dev-libs/glib-2.36:2
>=mate-base/mate-panel-1.6[gtk3(-)=]
>=x11-libs/cairo-1.0.4:0
x11-libs/gdk-pixbuf:2
virtual/libintl:0
!gtk3? ( >=x11-libs/gtk+-2.24:2 )
gtk3? ( >=x11-libs/gtk+-3.0:3 )
hddtemp? (
dbus? (
>=dev-libs/dbus-glib-0.80:0
>=dev-libs/libatasmart-0.16:0 )
!dbus? ( >=app-admin/hddtemp-0.3_beta13:0 ) )
libnotify? ( >=x11-libs/libnotify-0.7:0 )
lm_sensors? ( sys-apps/lm_sensors:0 )
video_cards_fglrx? ( x11-drivers/ati-drivers:* )
video_cards_nvidia? ( || (
>=x11-drivers/nvidia-drivers-100.14.09:0[static-libs,tools]
media-video/nvidia-settings:0
) )"

RDEPEND="${COMMON_DEPEND}"

DEPEND="${COMMON_DEPEND}
app-text/rarian:0
>=app-text/scrollkeeper-dtd-1:1.0
app-text/yelp-tools:0
>=dev-util/intltool-0.50.1:*
sys-devel/gettext:*
virtual/pkgconfig:*"

PDEPEND="hddtemp? ( dbus? ( sys-fs/udisks:0 ) )"

src_configure() {
local udisks

if use hddtemp && use dbus; then
udisks="--enable-udisks"
else
udisks="--disable-udisks"
fi

mate_src_configure \
--disable-static \
--with-gtk=$(usex gtk3 3.0 2.0) \
$(use_enable libnotify) \
$(use_with lm_sensors libsensors) \
$(use_with video_cards_fglrx aticonfig) \
$(use_with video_cards_nvidia nvidia) \
${udisks}
}

0 comments on commit 87368c6

Please sign in to comment.