forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
2 changed files
with
66 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST glibmm-2.48.1.tar.xz 6235724 SHA256 dc225f7d2f466479766332483ea78f82dc349d59399d30c00de50e5073157cdf SHA512 280949315e592ff8f3f7cfa6376d129211ffb6832146578d6533c4792aafef8b4ea5354943d5623ebf34ce31b8c71b6055a51de2b8ae8cfb419e6e033d9f98fa WHIRLPOOL 81c369bf7bf7ebc1f88e47943ed4b352644cad05566ec2fa04f0974a9e48dbc56b3cbd2f3bde9f55412da886e9b99fde096a1936834c65c77ede3781be30e0fd | ||
DIST glibmm-2.50.0.tar.xz 6435208 SHA256 df726e3c6ef42b7621474b03b644a2e40ec4eef94a1c5a932c1e740a78f95e94 SHA512 ed1043fbb5d16dfcb1e71f73e2c998110aa0dbc42b3fc9d8d1cc03e299b171021f2d2ac3055f5685d11b4dc1ddef42d9378eaac895163ddd80f39a627cecdc60 WHIRLPOOL b9c6867876311381b986f5123b6574bae01b45054e80a00c83688d756ed2a8e213dc3b1153a0aeb2672d9db998771fd6f538e1d592ffcb695ff7ac6147094975 | ||
DIST glibmm-2.50.1.tar.xz 6444576 SHA256 1fd85051da9cb402cc8348cec72dfe4d79f9345df4a1dbf68703a4ded45846a4 SHA512 4f25c75c1628ca2f4db1c29cebc63187d372603066b06aa6a66c6da792f9e02cb4a413e41f058a81e2d5a2b38d625de13df76115b278f010ce2fc493fe6e6bbb WHIRLPOOL 54b656e04550a050994061db1498a3ac066b1e37643faa218ec1ef04604c0d37c799572b546e79c29f1b35586b1a5b0c354eca72151756eb99f4434a27fa7ae2 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,65 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit gnome2 multilib-minimal | ||
|
||
DESCRIPTION="C++ interface for glib2" | ||
HOMEPAGE="http://www.gtkmm.org" | ||
|
||
LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system | ||
SLOT="2" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris" | ||
IUSE="doc debug test" | ||
|
||
RDEPEND=" | ||
>=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}] | ||
>=dev-libs/glib-2.50.0:2[${MULTILIB_USEDEP}] | ||
" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig | ||
doc? ( app-doc/doxygen ) | ||
" | ||
# dev-cpp/mm-common needed for eautoreconf | ||
|
||
src_prepare() { | ||
if ! use test; then | ||
# don't waste time building tests | ||
sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \ | ||
-i Makefile.am Makefile.in || die "sed 1 failed" | ||
fi | ||
|
||
# don't build examples - we want to install example sources, not binaries | ||
sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \ | ||
-i Makefile.am Makefile.in || die "sed 2 failed" | ||
|
||
gnome2_src_prepare | ||
} | ||
|
||
multilib_src_configure() { | ||
ECONF_SOURCE="${S}" gnome2_src_configure \ | ||
$(use_enable debug debug-refcounting) \ | ||
$(multilib_native_use_enable doc documentation) \ | ||
--enable-deprecated-api | ||
} | ||
|
||
multilib_src_test() { | ||
cd tests | ||
default | ||
|
||
for i in */test; do | ||
${i} || die "Running tests failed at ${i}" | ||
done | ||
} | ||
|
||
multilib_src_install() { | ||
gnome2_src_install | ||
} | ||
|
||
multilib_src_install_all() { | ||
einstalldocs | ||
|
||
find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null | ||
find examples -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null | ||
dodoc -r examples | ||
} |