Skip to content

Commit

Permalink
net-libs/jreen: Drop USE qt4,qt5
Browse files Browse the repository at this point in the history
Build Qt5-based only.

Package-Manager: Portage-2.3.16, Repoman-2.3.6
  • Loading branch information
a17r committed Nov 27, 2017
1 parent e68151c commit 882bf43
Showing 1 changed file with 39 additions and 0 deletions.
39 changes: 39 additions & 0 deletions net-libs/jreen/jreen-1.3.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

if [[ ${PV} != *9999* ]]; then
SRC_URI="https://github.com/euroelessar/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~ppc ~x86"
else
GIT_ECLASS="git-r3"
EGIT_REPO_URI="https://github.com/euroelessar/${PN}.git"
fi

inherit cmake-utils ${GIT_ECLASS}

DESCRIPTION="Qt XMPP library"
HOMEPAGE="https://github.com/euroelessar/jreen"

LICENSE="GPL-2"
SLOT="0"
IUSE="debug"

DEPEND="
dev-qt/qtcore:5
dev-qt/qtnetwork:5
media-libs/speex
net-libs/libgsasl
sys-libs/zlib
"
RDEPEND="${DEPEND}"

DOCS=( AUTHORS ChangeLog README.md )

src_configure() {
local mycmakeargs=(
-DJREEN_FORCE_QT4=OFF
)
cmake-utils_src_configure
}

0 comments on commit 882bf43

Please sign in to comment.