Skip to content

Commit

Permalink
games-mud/crystal: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Aug 5, 2016
1 parent e78d65c commit 89e172d
Show file tree
Hide file tree
Showing 3 changed files with 47 additions and 6 deletions.
41 changes: 41 additions & 0 deletions games-mud/crystal/crystal-0.2.4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit autotools eutils

DESCRIPTION="The crystal MUD client"
HOMEPAGE="http://www.evilmagic.org/crystal/"
SRC_URI="http://www.evilmagic.org/dist/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

RDEPEND="
dev-libs/openssl:0=
sys-libs/ncurses:0=
sys-libs/zlib
virtual/libiconv"
DEPEND="${RDEPEND}
virtual/pkgconfig"

PATCHES=(
"${FILESDIR}"/${P}-gcc43.patch
"${FILESDIR}"/${P}-build.patch
)

src_prepare() {
default

# avoid colliding with xscreensaver (bug #281191)
mv crystal.6 crystal-mud.6 || die
mv configure.in configure.ac || die
eautoreconf
}

src_configure() {
econf --disable-scripting
}
8 changes: 4 additions & 4 deletions games-mud/crystal/files/crystal-0.2.4-build.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- configure.in
+++ configure.in
--- a/configure.in
+++ b/configure.in
@@ -31,7 +31,9 @@
AC_PROG_CXX
AC_CHECK_FUNCS(select socket strerror strstr)
Expand All @@ -11,8 +11,8 @@

AC_CHECK_LIB(z, main, [LIBS=$LIBS" -lz "; AC_DEFINE(HAVE_ZLIB)], AC_MSG_WARN([No zlib - MCCP support will not be built]))

--- Makefile.am
+++ Makefile.am
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,11 @@
common.h crystal.h grid.h io.h telnet.h wcwidth.c \
scripting.cc scripting.h
Expand Down
4 changes: 2 additions & 2 deletions games-mud/crystal/files/crystal-0.2.4-gcc43.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- common.h
+++ common.h
--- a/common.h
+++ b/common.h
@@ -3,6 +3,8 @@

#include <string>
Expand Down

0 comments on commit 89e172d

Please sign in to comment.