Skip to content

Commit

Permalink
app-portage/eix: Version bump (bug 620932, thanks Martin Väth).
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
xmw committed Jun 7, 2017
1 parent 29c93fa commit 8adb89d
Show file tree
Hide file tree
Showing 2 changed files with 113 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/eix/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST eix-0.32.4.tar.xz 592284 SHA256 8132be9c496b5b19699c50d9aacd49560ca1f0466e3de4f47b896337f3527fc6 SHA512 382181d082648e9b236c3bf54fdf5d75a8575a7994e6a1d3380e80bcc36ff5779c660c5b5fc5f233cef79e48099fc53bb1c8b87e2ca919dcdb43d5fde276f553 WHIRLPOOL 0c8258d36a30a76fec2e7315e07776c277b2f098f6c0fb0a9a182f28827a659c334b190e10c52ea7ec8facd7a6e1f6124b3ffefd3ed2aade6da747e815276737
DIST eix-0.32.5.tar.xz 595124 SHA256 1ebe07f46800f3f254d1385cd88eba328da9f07cc17731ad1b231a8b13450f6e SHA512 355c0daf81c349ceaa53a7253816a072578923f2044e53c9a8e98ceb9726b238f86f8b1d8ad96bb62851f887e50c1e5e443115dc12fcae7c8bca851caf9b9650 WHIRLPOOL 3b707ebeadc1653917269c81a594469ff2c603e5ad3772d1b19efb9fbd81dcf76b527c9d03975748e9cf0e1f011d1704ecd39f108ea166d78c9bb3be7370ada7
DIST eix-0.32.9.tar.xz 599072 SHA256 0929581db3282a81a82ab9e17e6522a6517609de96f3a22ab7c081d0c3288edd SHA512 1a7c3d5f371150f5990fe1f1c4cadb0e3ee0a5810011702904aabd58ca250c10f820d6c64e7182096e0b7e2aa001cf573c5f2e83499ceb350cc59b599ec2ca5b WHIRLPOOL d22f2c536baeb2d2204800b6d8600d27c6933b1f89f1b09954fbc2945939d9981d26d8f20f05b066e2edae75dba6db5b41e37273d19d36481946e106699bc95f
112 changes: 112 additions & 0 deletions app-portage/eix/eix-0.32.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,112 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PLOCALES="de ru"
inherit autotools bash-completion-r1 l10n systemd flag-o-matic

DESCRIPTION="Search and query ebuilds"
HOMEPAGE="https://github.com/vaeth/eix/"
SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="debug doc nls sqlite"

BOTHDEPEND="nls? ( virtual/libintl )
sqlite? ( >=dev-db/sqlite-3:= )"
RDEPEND="${BOTHDEPEND}
>=app-shells/push-2.0-r1
>=app-shells/quoter-3.0_p2-r1"
DEPEND="${BOTHDEPEND}
app-arch/xz-utils
nls? ( sys-devel/gettext )"

pkg_setup() {
# remove stale cache file to prevent collisions
local old_cache=${EROOT%/}/var/cache/${PN}
if [[ -f ${old_cache} ]]; then
rm "${old_cache}" || die
fi
}

src_prepare() {
default
sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die

sed -e "/eixf_source=/s:push.sh:cat \"${EROOT}usr/share/push/push.sh\":" \
-e "/eixf_source=/s:quoter_pipe.sh:cat \"${EROOT}usr/share/quoter/quoter_pipe.sh\":" \
-i src/eix-functions.sh.in || die
sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EROOT}usr/share/eix/eix-functions.sh\\\\\":" \
-i src/Makefile.am || die
eautoreconf
}

src_configure() {
local myconf=(
$(use_enable debug paranoicasserts)
$(use_enable nls)
$(use_with doc extra-doc)
$(use_with sqlite)

# default configuration
$(use_with prefix always-accept-keywords)
--with-dep-default
--with-required-use-default

# paths
--with-portage-rootpath="${ROOTPATH}"
--with-eprefix-default="${EPREFIX}"

# build a single executable with symlinks
--disable-separate-binaries
--disable-separate-tools

# used purely to control/disrespect *FLAGS
--disable-debugging
--disable-new_dialect
--disable-optimization
--disable-strong-optimization
--disable-security
--disable-nopie-security
--disable-strong-security
)

# https://github.com/vaeth/eix/issues/35
append-cxxflags -std=c++11

econf "${myconf[@]}"
}

src_install() {
default
dobashcomp bash/eix
systemd_dotmpfilesd tmpfiles.d/eix.conf

insinto /usr/share/${PN}
doins "${ED}"/usr/bin/eix-functions.sh
rm -r "${ED}"/usr/bin/eix-functions.sh || die

keepdir /var/cache/eix
}

pkg_postinst() {
if ! use prefix; then
# note: if this is done in src_install(), portage:portage
# ownership may be reset to root
chown portage:portage "${EROOT%/}"/var/cache/eix || die
fi

local obs=${EROOT%/}/var/cache/eix.previous
if [[ -f ${obs} ]]; then
ewarn "Found obsolete ${obs}, please remove it"
fi
}

pkg_postrm() {
if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
rm -rf "${EROOT%/}/var/cache/${PN}" || die
fi
}

0 comments on commit 8adb89d

Please sign in to comment.