Skip to content

Commit

Permalink
media-libs/audiofile: fix mingw32 build
Browse files Browse the repository at this point in the history
Pick upstream patch for s/bzero()/memset()/

Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
Sergei Trofimovich committed Jun 8, 2017
1 parent aa40c7f commit 8b9209b
Show file tree
Hide file tree
Showing 2 changed files with 21 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/audiofile/audiofile-0.3.6-r3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -22,6 +22,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.3.6-gcc6-build-fixes.patch
"${FILESDIR}"/${PN}-0.3.6-system-gtest.patch
"${FILESDIR}"/${PN}-0.3.6-CVE-2015-7747.patch
"${FILESDIR}"/${PN}-0.3.6-mingw32.patch
)

src_prepare() {
Expand Down
20 changes: 20 additions & 0 deletions media-libs/audiofile/files/audiofile-0.3.6-mingw32.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
bzero() is a POSIX-specific fuinction.
x86_64-w64-mingw32-gcc does not provide one.

https://github.com/mpruett/audiofile/commit/d9363a5d16af4ce55eb35c5aad9ca19bb9c53cbe

commit d9363a5d16af4ce55eb35c5aad9ca19bb9c53cbe
Author: Daniel Verkamp <[email protected]>
Date: Mon Jul 4 21:57:44 2016 -0500

Replace bzero() with memset().

diff --git a/libaudiofile/CAF.cpp b/libaudiofile/CAF.cpp
index d2b62ea..5752117 100644
--- a/libaudiofile/CAF.cpp
+++ b/libaudiofile/CAF.cpp
@@ -720,3 +720,3 @@ void CAFFile::initALACCompressionParams()
m_codecData = new Buffer(codecDataSize);
- bzero(m_codecData->data(), m_codecData->size());
+ memset(m_codecData->data(), 0, m_codecData->size());

0 comments on commit 8b9209b

Please sign in to comment.