Skip to content

Commit

Permalink
media-sound/amarok: Fix build w/ gcc-6
Browse files Browse the repository at this point in the history
By adding upstreamed patch from opensuse.

Gentoo-bug: 584682

Package-Manager: portage-2.3.0_rc1
  • Loading branch information
johu committed Jun 1, 2016
1 parent a73d133 commit 8bfde08
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/amarok/amarok-2.8.90-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -77,6 +77,7 @@ PATCHES=(
"${FILESDIR}/${P}-mysql-embedded.patch"
"${FILESDIR}/${P}-mysqld-rpath.patch"
"${FILESDIR}/${P}-scriptconsole.patch"
"${FILESDIR}/${P}-gcc6.patch"
)

src_configure() {
Expand Down
36 changes: 36 additions & 0 deletions media-sound/amarok/files/amarok-2.8.90-gcc6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
From 9308403e1c8484052f277bf6de32ee07c93a4beb Mon Sep 17 00:00:00 2001
From: Rex Dieter <[email protected]>
Date: Wed, 1 Jun 2016 13:58:26 -0500
Subject: [PATCH] gcc6 buildfix

courtesy of opensuse, thx

BUG: 363054
---
src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp b/src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp
index 4bdb9b9..e327354 100644
--- a/src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp
+++ b/src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp
@@ -28,6 +28,7 @@
#include "playlist/PlaylistModelStack.h"

using namespace Playlists;
+using namespace Playlist;

XSPFPlaylist::XSPFPlaylist( const KUrl &url, Playlists::PlaylistProvider *provider, OnLoadAction onLoad )
: PlaylistFile( url, provider )
@@ -101,7 +102,7 @@ XSPFPlaylist::load()
//FIXME: this needs to be moved to whatever is creating the XSPFPlaylist
if( m_autoAppendAfterLoad )
The::playlistController()->insertPlaylist(
- ::Playlist::ModelStack::instance()->bottom()->rowCount(),
+ ModelStack::instance()->bottom()->rowCount(),
Playlists::PlaylistPtr( this )
);
}
--
2.8.3

0 comments on commit 8bfde08

Please sign in to comment.