Skip to content

Commit

Permalink
app-vim/editorconfig-vim: New package, an EditorConfig plugin for vim
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
chutz committed Nov 4, 2016
1 parent 77bb515 commit 8c3b908
Show file tree
Hide file tree
Showing 3 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-vim/editorconfig-vim/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST editorconfig-vim-0.3.3.tar.gz 35395 SHA256 fd579672c426a089835e9bc57a1fd5fc18dba77c014b67141153372e83c92c57 SHA512 2dd968cf6bb162db8e6242ffb60cc61fb05a8042804b6b46b9f9cd35be968f83b473f04797e47c5cff11d7c052ff523bf8ba1d568992d44b72b97b54a81425a1 WHIRLPOOL 580e4ee8a5dc3bd2c17334ba40f7e89436111c26cbdf4c2f248f4c0a862739c3e3a17124b0750a791bbb4e8602484c33da4fe0ea20c5988ae94485b181fe4e8b
46 changes: 46 additions & 0 deletions app-vim/editorconfig-vim/editorconfig-vim-0.3.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=(python2_7)
inherit vim-plugin distutils-r1

DESCRIPTION="vim plugin: Support EditorConfig files "
HOMEPAGE="http://editorconfig.org/"
LICENSE="BSD-2"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/${PN%-vim}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

DEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )"

VIM_PLUGIN_HELPFILES="${PN%-vim}.txt"

PYTHON_S="${S}/plugin/${PN%-vim}-core-py"

src_prepare() {
default
pushd "${PYTHON_S}" > /dev/null
python_setup
distutils-r1_src_prepare
popd > /dev/null

rm LICENSE mkzip.sh .editorconfig .gitignore .travis.yml || die
rm -r tests || die
}

python_compile() {
pushd "${PYTHON_S}" > /dev/null
distutils-r1_python_compile
popd > /dev/null
}

src_install() {
pushd "${PYTHON_S}" > /dev/null
distutils-r1_src_install
popd > /dev/null

rm -r "${PYTHON_S}"
vim-plugin_src_install
}
11 changes: 11 additions & 0 deletions app-vim/editorconfig-vim/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
</maintainer>
<maintainer type="person">
<email>[email protected]</email>
<name>Patrick McLean</name>
</maintainer>
</pkgmetadata>

0 comments on commit 8c3b908

Please sign in to comment.