Skip to content

Commit

Permalink
media-fonts/noto-cjk: Version bump
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/616974
Signed-off-by: Pacho Ramos <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
pacho2 committed Oct 20, 2018
1 parent 6aadc73 commit 8d785e6
Show file tree
Hide file tree
Showing 3 changed files with 175 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-fonts/noto-cjk/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST noto-cjk-20150615.tar.xz 390518224 BLAKE2B 273018f6d0792ae90bc0d9f44a43f300a7fbd2ca2cbdbf71af911e1cfc0d4f0bb30b5d1f2b15d9bf4df279266921d46987f166dd4559ea15e747db7a22494145 SHA512 738bd840d14c3fc3665b9c6e50b1b2d5981ccdc5e660a6498b4611b8019208f0880df062741d9dec8bdcd54234eed46655e1c739cf872d9dfa5fa0523954a7d3
DIST noto-cjk-20170602.tar.gz 1667938394 BLAKE2B 51ed7c48bccef0dff75ddc5ec108b61f0f5ceedc41608919dc1071a2308f96c3d2883af932935c32db6dd017e067079d45776eb865200560f2f9c6b89e57dd8c SHA512 861431e1eb0c21b8b7b03f9a97ae61c59a2e513314a24f0c50e2953daac3cba78fa418af32cf66ec100a26c88f5e07bd33eb3ed80b533d97a452fefa5a06b4dc
147 changes: 147 additions & 0 deletions media-fonts/noto-cjk/files/70-noto-cjk.conf
Original file line number Diff line number Diff line change
@@ -0,0 +1,147 @@
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<match target="pattern">
<test name="lang">
<string>ja</string>
</test>
<test name="family">
<string>serif</string>
</test>
<edit name="family" mode="prepend">
<string>Noto Serif CJK JP</string>
</edit>
</match>

<match target="pattern">
<test name="lang">
<string>ko</string>
</test>
<test name="family">
<string>serif</string>
</test>
<edit name="family" mode="prepend">
<string>Noto Serif CJK KR</string>
</edit>
</match>

<match target="pattern">
<test name="lang">
<string>zh-cn</string>
</test>
<test name="family">
<string>serif</string>
</test>
<edit name="family" mode="prepend">
<string>Noto Serif CJK SC</string>
</edit>
</match>

<match target="pattern">
<test name="lang">
<string>zh-tw</string>
</test>
<test name="family">
<string>serif</string>
</test>
<edit name="family" mode="prepend">
<string>Noto Serif CJK TC</string>
</edit>
</match>

<match target="pattern">
<test name="lang">
<string>ja</string>
</test>
<test name="family">
<string>sans-serif</string>
</test>
<edit name="family" mode="prepend">
<string>Noto Sans CJK JP</string>
</edit>
</match>

<match target="pattern">
<test name="lang">
<string>ko</string>
</test>
<test name="family">
<string>sans-serif</string>
</test>
<edit name="family" mode="prepend">
<string>Noto Sans CJK KR</string>
</edit>
</match>

<match target="pattern">
<test name="lang">
<string>zh-cn</string>
</test>
<test name="family">
<string>sans-serif</string>
</test>
<edit name="family" mode="prepend">
<string>Noto Sans CJK SC</string>
</edit>
</match>

<match target="pattern">
<test name="lang">
<string>zh-tw</string>
</test>
<test name="family">
<string>sans-serif</string>
</test>
<edit name="family" mode="prepend">
<string>Noto Sans CJK TC</string>
</edit>
</match>

<match target="pattern">
<test name="lang">
<string>ja</string>
</test>
<test name="family">
<string>monospace</string>
</test>
<edit name="family" mode="prepend">
<string>Noto Sans Mono CJK JP</string>
</edit>
</match>

<match target="pattern">
<test name="lang">
<string>ko</string>
</test>
<test name="family">
<string>monospace</string>
</test>
<edit name="family" mode="prepend">
<string>Noto Sans Mono CJK KR</string>
</edit>
</match>

<match target="pattern">
<test name="lang">
<string>zh-cn</string>
</test>
<test name="family">
<string>monospace</string>
</test>
<edit name="family" mode="prepend">
<string>Noto Sans Mono CJK SC</string>
</edit>
</match>

<match target="pattern">
<test name="lang">
<string>zh-tw</string>
</test>
<test name="family">
<string>monospace</string>
</test>
<edit name="family" mode="prepend">
<string>Noto Sans Mono CJK TC</string>
</edit>
</match>
</fontconfig>
27 changes: 27 additions & 0 deletions media-fonts/noto-cjk/noto-cjk-20170602.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit font

DESCRIPTION="Google's CJK font family"
HOMEPAGE="https://www.google.com/get/noto/ https://github.com/googlei18n/noto-cjk"

COMMIT="32a5844539f2e348ed36b44e990f9b06d7fb89fe"
SRC_URI="https://github.com/googlei18n/noto-cjk/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"

LICENSE="OFL-1.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE=""

RESTRICT="binchecks strip"

S="${WORKDIR}/${PN}-${COMMIT}"

FONT_S="${S}"
FONT_SUFFIX="ttc otf"
FONT_CONF=(
# From ArchLinux
"${FILESDIR}/70-noto-cjk.conf"
)

0 comments on commit 8d785e6

Please sign in to comment.