forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
xfce-extra/xfce4-screensaver: Bump to 0.1.2
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
70 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST xfce4-screensaver-0.1.0.tar.bz2 525080 BLAKE2B be1b4add2f72cf7d93bcb651852bb398c38e7d4637c03d90ea277dc3ea50147e8bca9a870b8b5fe2353fd71ad180684214cdeb0e18808f3ced234f9a03b2bf13 SHA512 a925deada7313e3d156d4b19fd38e50538e2ac429c657f9f29b727c4c20ccd83a07dafdc4fa14fca26bcc09961ee42700685097260473a5fdec8877114a8a048 | ||
DIST xfce4-screensaver-0.1.1.tar.bz2 599282 BLAKE2B efa5addab9ed3ec92a71ee129ad36d5491107c5352999bcd42c2e147c914095c343ced7adfc9d814cb0fcd3b880efd3fa76e6f5171f62d2432639f9be6b857df SHA512 b494810dbad3ae23676d4a403a8b00da7d33f5fc0520c59cf6b612626e0b4d1f642c9ed47c24c7ea2c051d9a1077396dacb807d623852c599d1538d089833071 | ||
DIST xfce4-screensaver-0.1.2.tar.bz2 598959 BLAKE2B 63ea3e6268cbd49ba72e43fb37c947c63fb0051ca62da9369806988ed1624ac20e8ece76b3ea2849d6e0b0049c0c10775285f1fd9b11c4856d7d842ce9c7ffc1 SHA512 9460ae8a3dec27df5e67bb078f8f52fb298769e572ae75c7a6ae4f0f5f7b93e430e505f99dce4caea0c6c885f9087270700e294150cdcfeadce5046049e44f6f |
69 changes: 69 additions & 0 deletions
69
xfce-extra/xfce4-screensaver/xfce4-screensaver-0.1.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,69 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
DESCRIPTION="Screen saver and locker (port of MATE screensaver)" | ||
HOMEPAGE="https://git.xfce.org/apps/xfce4-screensaver/about/" | ||
SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2+ LGPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="consolekit +locking opengl pam systemd" | ||
|
||
# Xrandr: optional but automagic | ||
RDEPEND=" | ||
dev-libs/dbus-glib | ||
>=dev-libs/glib-2.50:2 | ||
>=x11-libs/gtk+-3.22:3 | ||
x11-libs/libICE:= | ||
x11-libs/libX11:= | ||
x11-libs/libXScrnSaver:= | ||
x11-libs/libXext:= | ||
x11-libs/libXxf86misc:= | ||
x11-libs/libXxf86vm:= | ||
>=x11-libs/libXrandr-1.3:= | ||
>=x11-libs/libxklavier-5.2:= | ||
x11-misc/xscreensaver | ||
>=xfce-base/garcon-0.5.0:= | ||
>=xfce-base/libxfce4ui-4.12.1:= | ||
>=xfce-base/libxfce4util-4.12.1:= | ||
>=xfce-base/xfconf-4.12.1:= | ||
consolekit? ( sys-auth/consolekit ) | ||
locking? ( | ||
pam? ( virtual/pam ) | ||
) | ||
opengl? ( virtual/opengl ) | ||
systemd? ( sys-apps/systemd:= ) | ||
" | ||
DEPEND="${RDEPEND} | ||
dev-util/glib-utils | ||
dev-util/intltool | ||
sys-apps/dbus | ||
virtual/pkgconfig" | ||
|
||
src_configure() { | ||
local myconf=( | ||
# disable docbook for now | ||
ac_cv_path_XMLTO=no | ||
|
||
# xscreensaver dirs autodetection doesn't seem to work | ||
--with-xscreensaverdir=/usr/share/xscreensaver/config | ||
--with-xscreensaverhackdir=/usr/$(get_libdir)/misc/xscreensaver | ||
|
||
$(use_with opengl libgl) | ||
$(use_enable locking) | ||
$(use_enable pam) | ||
$(use_with consolekit console-kit) | ||
$(use_with systemd) | ||
) | ||
|
||
econf "${myconf[@]}" | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
find "${D}" -name '*.la' -delete || die | ||
} |