Skip to content

Commit

Permalink
app-accessibility/epos: Fix building with GCC-7
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/638596
Closes: https://bugs.gentoo.org/638596
Closes: gentoo#7760
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Closes: gentoo#7760
  • Loading branch information
Peter-Levine authored and a17r committed Apr 4, 2018
1 parent 0de1053 commit 8fbdb72
Show file tree
Hide file tree
Showing 2 changed files with 23 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-accessibility/epos/epos-2.5.37-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.5.37-gcc45.patch
"${FILESDIR}"/${PN}-2.5.37-gcc47.patch
"${FILESDIR}"/${PN}-2.5.37-disable-tests.patch
"${FILESDIR}"/${PN}-2.5.37-gcc7.patch
)

src_prepare() {
Expand Down
22 changes: 22 additions & 0 deletions app-accessibility/epos/files/epos-2.5.37-gcc7.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
Bug: https://bugs.gentoo.org/638596

--- a/src/nnet/matrix.cc
+++ b/src/nnet/matrix.cc
@@ -63,7 +63,7 @@
template<class T> void CMatrix<T>::multiplyByTransponed (const CMatrix &y, CMatrix &retval)
{
int i,j,k;
- assert (cols == y.cols);
+ this->assert (cols == y.cols);
if (cols != y.cols) { retval.Realloc (0,0); return; }

T sum;
@@ -80,7 +80,7 @@
template<class T> void CMatrix<T>::transponedMultiply (const CMatrix &y, CMatrix &retval)
{
int i,j,k;
- assert (rows == y.rows);
+ this->assert (rows == y.rows);
if (rows != y.rows) { retval.Realloc (0,0); return; }

T sum;

0 comments on commit 8fbdb72

Please sign in to comment.