Skip to content

Commit

Permalink
dev-lua/say: add luajit support
Browse files Browse the repository at this point in the history
Bump to EAPI 6
Add Test phase.

Gentoo-Bug: https://bugs.gentoo.org/628758
  • Loading branch information
lluixhi authored and mgorny committed Sep 2, 2017
1 parent bd0cdb2 commit 906bc29
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
4 changes: 4 additions & 0 deletions dev-lua/say/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -8,6 +8,10 @@
<longdescription lang="en">
Useful for internationalization.
</longdescription>
<use>
<flag name="luajit">Use <pkg>dev-lang/luajit</pkg> instead of
<pkg>dev-lang/lua</pkg></flag>
</use>
<upstream>
<remote-id type="github">Olivine-Labs/say</remote-id>
</upstream>
Expand Down
39 changes: 39 additions & 0 deletions dev-lua/say/say-1.3_p1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
MY_PV=1.3-1

inherit toolchain-funcs

DESCRIPTION="Lua String Hashing/Indexing Library"
HOMEPAGE="http://olivinelabs.com/busted/"
SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="luajit test"

RDEPEND="
!luajit? ( >=dev-lang/lua-5.1:= )
luajit? ( dev-lang/luajit:2 )"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-lua/busted )"

DOCS=( CONTRIBUTING.md README.md )

S="${WORKDIR}/${PN}-${MY_PV}"

src_test() {
busted -o gtest || die
}

src_install() {
local instdir
instdir="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"/${PN}
insinto "${instdir#${EPREFIX}}"
doins src/init.lua
einstalldocs
}

0 comments on commit 906bc29

Please sign in to comment.