forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Beierlein <[email protected]>
- Loading branch information
Showing
2 changed files
with
84 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST xlog-2.0.22.tar.gz 11407849 BLAKE2B 85d2e904d33ef39883cb8ac086eed4dc7e65503cdccb95e8d33f169d12de4f1ed556a28ac2f40e0044e937185bf4d93fe55608088d6e95744617c9c3a051fb55 SHA512 a261f8e28b75aed9380c29b3da69c7615b0d32346eaf84a0ace5cf77c53407372c4985c599078dba5ed92f77bd8052a74c7dca40028b99bca49cc3164d4ec490 | ||
DIST xlog-2.0.23.tar.gz 11407743 BLAKE2B 82828d043006b7f73ee32bae5b0beb261684aa70a2c556af34a8a269b790ad76e24d40a7ddb5c9b5cfd74ac7feb510c19deacc1b3dea647594d1f5f8c1293ca4 SHA512 1c235e6a49c7d6dd049aade4a0c34ffed61c211ea31c0f8d4d62db1a03b2d1e025ffd2fd9ae42b639113485d36e1ee2e40439f74e1971eb99847f4564b21bd10 | ||
DIST xlog-2.0.24.tar.gz 11407825 BLAKE2B 0de5203d4229005ba84940443672a9787a9ab2a87565bcbf47e0a0fcf375dcddec7636d11a359a117c42b7e07ea81fd482a2684b8a75379da1fe72cbc991643d SHA512 cc96dfabf01a6c49ed7db1257cc102a469642bdd32a158b0a026da2017181060f8aace5de22ada5df42b3bc89c14448dd372332a9ff0101121570f5b1187e5ab |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,83 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit autotools toolchain-funcs xdg-utils | ||
MY_P=${P/_} | ||
|
||
DESCRIPTION="An amateur radio logging program" | ||
HOMEPAGE="https://www.nongnu.org/xlog" | ||
SRC_URI="https://download.savannah.gnu.org/releases/${PN}/${MY_P}.tar.gz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND="media-libs/hamlib:= | ||
dev-libs/glib:2 | ||
x11-libs/gtk+:2" | ||
DEPEND="${RDEPEND} | ||
media-libs/libpng:0 | ||
sys-devel/gettext | ||
virtual/pkgconfig" | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
DOCS=( AUTHORS data/doc/THANKS NEWS README ) | ||
|
||
src_prepare() { | ||
eapply_user | ||
eapply -p0 "${FILESDIR}/${PN}-2.0.7-desktop.patch" | ||
|
||
# Drop -Werror | ||
sed -i -e "s:-Werror::g" configure.ac || die | ||
# fix underlinking | ||
sed -i -e "s:HAMLIB_LIBS@:HAMLIB_LIBS@ -lm:g" src/Makefile.am || die | ||
eautoconf | ||
|
||
# prepare for media-radio/hamlib-4.2 change of API | ||
if has_version '>=media-libs/hamlib-4.2' ; then | ||
sed -i -e "s/FILPATHLEN/HAMLIB_FILPATHLEN/g" "${S}"/src/hamlib-utils.c || die | ||
fi | ||
|
||
# Fix broken png files<< | ||
einfo "Fixing broken png files." | ||
pushd "${S}"/data/doc/manual/output/html | ||
for png in xlog-clock.png xlog-dropdown.png xlog-editbox.png; do | ||
pngfix -q --out=out.png ${png} | ||
mv -f out.png "${png}" || die | ||
done | ||
popd | ||
einfo "done ..." | ||
|
||
} | ||
|
||
src_configure() { | ||
# mime-update causes file collisions if enabled | ||
econf --disable-mime-update | ||
} | ||
|
||
src_compile() { | ||
emake AR="$(tc-getAR)" | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" install | ||
# build system makes it complicate to inhibit updating desktop | ||
# database, so just remove the offending file | ||
rm "${D}"/usr/share/applications/mimeinfo.cache || die | ||
docompress -x /usr/share/doc/${PF}/{KEYS,ChangeLog,TODO,BUGS} | ||
einstalldocs | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_desktop_database_update | ||
xdg_mimeinfo_database_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_desktop_database_update | ||
xdg_mimeinfo_database_update | ||
} |