Skip to content

Commit

Permalink
dev-lang/moarvm: Bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Patrick Lauer <[email protected]>
  • Loading branch information
patricklauer committed Jul 28, 2019
1 parent 6cae10d commit 9255e2b
Show file tree
Hide file tree
Showing 3 changed files with 89 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/moarvm/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST MoarVM-2018.08.tar.gz 5047553 BLAKE2B bcb3350e4a063958eee508885784f3f8eda20
DIST MoarVM-2018.09.tar.gz 5070458 BLAKE2B 6c391907eb7bcda7eb6629d9f1aea16414fa9ee62d97ec3c72cea6c9b8f6323ef2869e560d8574d30b339889aff92ad73cfd174f9b23f4a98ef359873e053a94 SHA512 14d5ca1f6a8c77ee89fd05d66057b640b1e222391fded17631a4e11801de25e1fb3eb6b8b4dd977990e64952f7067482bf405a9ef5ebb6fdacdfa7c11bee21b1
DIST MoarVM-2018.12.tar.gz 5238765 BLAKE2B ac0a7ba8107bcf79cfa58011c0968b5c960d9b2f2e59754b25a2f29e66f86e1d2524e16bce84323f2426f264476a4f3d307761c340ca6f09d3983eacde336704 SHA512 b55efc942a581e1d14a571b44a58a76e18f01ca1fabb4c68476003bb42fd4f3663fd532e75814cad6f7b1e1cf5562fe6b1aa68b956c1d8e6769e9dc1bce2b0a7
DIST MoarVM-2019.03.tar.gz 5136086 BLAKE2B 695e5528934002b17f547a281482dc0015b3901b2c9626ce6fcf8aaa2df07c293f501871311ee3be47d009b972ca22a268bb34c859fde6a13566e8d03d1d3f04 SHA512 aa50dcf1499e83247c4c490384f80896160d08fb72a5a6da1f91748c6dc343fa30dcf35adca3e9e8329a2919026a4bdb299129865abf611ce49d73d05cce4285
DIST MoarVM-2019.07.tar.gz 5187102 BLAKE2B a9c56453edf5b5834d33187aea6eabacac9a721e7a27471a02b82585560ffbb5bb8807ae8c738f3138c5b0453217ad101aab23bef2c8b727cd2f8a56574abfd5 SHA512 ff5370cb2c7dc4357825f02387757e36a5e03b711021c896043ba5f68e573308146a0d94c7855ec9b4860906a3b0720d316d119ca5bbda908f17d3f4f14f4999
28 changes: 28 additions & 0 deletions dev-lang/moarvm/files/fix-quoting.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
From f1b26bb0e8f4e0a00ac31f9defb1ed74b820eb39 Mon Sep 17 00:00:00 2001
From: Stefan Seifert <[email protected]>
Date: Mon, 15 Jul 2019 12:04:45 +0200
Subject: [PATCH] Fix Configure.pl failing when --prefix /usr is passed

gerd++ reported this on Github 1143 and supplied the diagnostics and
fix:
If the prefix is exact /usr, then it seems that in build/Makefile.in
@moardll@: $(OBJECTS) $(THIRDPARTY)
$(MSG) linking $@
$(CMD)$(LD) @ldout@$@ $(LDFLAGS) @ldshared@ @moarshared@ $(OBJECTS) $(DLL_LIBS)
moarshared will not be substituted or is wrong.
---
Configure.pl | 1 +
1 file changed, 1 insertion(+)

diff --git a/Configure.pl b/Configure.pl
index b71b576be..753dcfaac 100755
--- a/Configure.pl
+++ b/Configure.pl
@@ -441,6 +441,7 @@ sub uniq {
push @ldflags, $ENV{LDFLAGS} if $ENV{LDFLAGS};
$config{ldflags} = join ' ', @ldflags;

+$config{moarshared} = '';
# Switch shared lib compiler flags in relocatable case.
if (not $args{static} and $config{prefix} ne '/usr') {
$config{moarshared} = $config{moarshared_relocatable} if $args{relocatable};
60 changes: 60 additions & 0 deletions dev-lang/moarvm/moarvm-2019.07.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit flag-o-matic

MY_PN="MoarVM"
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
inherit git-r3
KEYWORDS=""
S="${WORKDIR}/${P}"
else
SRC_URI="http://moarvm.org/releases/${MY_PN}-${PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi

DESCRIPTION="A 6model-based VM for NQP and Rakudo Perl 6"
HOMEPAGE="http://moarvm.org"
LICENSE="Artistic-2"
SLOT="0"

#USE=optimize triggers makefile bug
IUSE="asan clang debug doc +jit static-libs ubsan"

RDEPEND="dev-libs/libatomic_ops
>=dev-libs/libuv-1.26
dev-lang/lua:=
virtual/libffi"
DEPEND="${RDEPEND}
clang? ( >=sys-devel/clang-3.1 )
dev-lang/perl"

DOCS=( CREDITS README.markdown )

# Tests are conducted via nqp
RESTRICT=test

# known configure bug
PATCHES="${FILESDIR}/fix-quoting.patch"

src_configure() {
use doc && DOCS+=( docs/* )
local myconfigargs=(
"--prefix" "/usr"
"--has-libuv"
"--has-libatomic_ops"
"--has-libffi"
"--libdir" "$(get_libdir)"
"--compiler" "$(usex clang clang gcc)"
"$(usex asan --asan)"
"$(usex debug --debug --no-debug)"
"$(usex static-libs --static)"
"$(usex ubsan --ubsan)"
)

perl Configure.pl "${myconfigargs[@]}" moarshared || die
}

0 comments on commit 9255e2b

Please sign in to comment.