Skip to content

Commit

Permalink
dev-qt/qtcore: Fix headers for revdeps building with GCC-11
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/768342
Closes: https://bugs.gentoo.org/768354
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Feb 13, 2021
1 parent 0886d5f commit 92d54be
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 0 deletions.
38 changes: 38 additions & 0 deletions dev-qt/qtcore/files/qtcore-5.15.2-gcc11.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
Description: include <limits> to fix some GCC 11 build issues
Origin: upstream, commits:
https://code.qt.io/cgit/qt/qtbase.git/commit/?id=813a928c7c3cf986
https://code.qt.io/cgit/qt/qtbase.git/commit/?id=9c56d4da2ff631a8
Last-Update: 2021-01-26

--- a/src/corelib/global/qendian.h
+++ b/src/corelib/global/qendian.h
@@ -44,6 +44,8 @@
#include <QtCore/qfloat16.h>
#include <QtCore/qglobal.h>

+#include <limits>
+
// include stdlib.h and hope that it defines __GLIBC__ for glibc-based systems
#include <stdlib.h>
#include <string.h>
--- a/src/corelib/global/qfloat16.h
+++ b/src/corelib/global/qfloat16.h
@@ -43,6 +43,7 @@

#include <QtCore/qglobal.h>
#include <QtCore/qmetatype.h>
+#include <limits>
#include <string.h>

#if defined(QT_COMPILER_SUPPORTS_F16C) && defined(__AVX2__) && !defined(__F16C__)
--- a/src/corelib/text/qbytearraymatcher.h
+++ b/src/corelib/text/qbytearraymatcher.h
@@ -42,6 +42,8 @@

#include <QtCore/qbytearray.h>

+#include <limits>
+
QT_BEGIN_NAMESPACE


1 change: 1 addition & 0 deletions dev-qt/qtcore/qtcore-5.15.2-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -52,6 +52,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.15.1-timezone-{1,2}.patch # bug 737914
"${FILESDIR}"/${P}-fix-UB-in-QDateTime.patch # QTBUG-88656
"${FILESDIR}"/${P}-fix-alloc-mem-of-QByteArray.patch # QTBUG-87010
"${FILESDIR}"/${P}-gcc11.patch # bug 768342, 768354
"${WORKDIR}"/qtbase-${PV}-gcc11.patch # bug 752012
)

Expand Down

0 comments on commit 92d54be

Please sign in to comment.