Skip to content

Commit

Permalink
dev-vcs/gitstats-0_pre131024: fix bug #575946
Browse files Browse the repository at this point in the history
Gentoo-bug: 575946
Reported-by: Martin Mokrejš

Package-Manager: portage-2.2.28
  • Loading branch information
amadio committed Mar 24, 2016
1 parent 9890d14 commit 93107b6
Show file tree
Hide file tree
Showing 2 changed files with 13 additions and 1 deletion.
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- gitstats 2016-03-24 10:57:18.000000000 -0300
+++ gitstats.mod 2016-03-24 10:57:11.355016439 -0300
@@ -321,7 +321,7 @@

# Collect revision statistics
# Outputs "<stamp> <date> <time> <timezone> <author> '<' <mail> '>'"
- lines = getpipeoutput(['git rev-list --pretty=format:"%%at %%ai %%aN <%%aE>" %s' % getcommitrange('HEAD'), 'grep -v ^commit']).split('\n')
+ lines = getpipeoutput(['git rev-list --pretty=format:"%%at %%ai %%aN <%%aE>" %s' % getcommitrange('HEAD'), 'grep -av ^commit | grep -ax \'.*\'']).split('\n')
for line in lines:
parts = line.split(' ', 4)
author = ''
3 changes: 2 additions & 1 deletion dev-vcs/gitstats/gitstats-0_pre131024.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -26,6 +26,7 @@ src_prepare() {
sed \
-e "s:basedir = os.path.dirname(os.path.abspath(__file__)):basedir = '${EPREFIX}/usr/share/gitstats':g" \
-i gitstats || die "failed to fix static files path"
epatch "${FILESDIR}"/${P}-filter-invalid-unicode.patch
}

src_compile() {
Expand Down

0 comments on commit 93107b6

Please sign in to comment.