Skip to content

Commit

Permalink
mail-client/cone: version bump to 1.0
Browse files Browse the repository at this point in the history
Signed-off-by: Tim Harder <[email protected]>
  • Loading branch information
radhermit committed Dec 25, 2018
1 parent e3abc64 commit 9370de7
Show file tree
Hide file tree
Showing 3 changed files with 120 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-client/cone/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST cone-0.92.tar.bz2 3774451 BLAKE2B 3686ca90249f38c0be83138bf310802f5a5ea1e0694abef5ec9311a00e9c81692abf2148cf23640932ba1fe0c49ea6738689189c618412e985b02a45dba9c7a4 SHA512 8d764ed3cb2a22caff21d11beff74131fdbbe0f66dbf1a40293f62862e9af7a472840ff00a069df10143f7154c2db85ac5421999476516f27b8f090e5c1232fc
DIST cone-0.95.tar.bz2 3748331 BLAKE2B 9461cc28afb255e7ca4080e4c876f5391e916c493b6596b0bfc0ec2d0cedb837d10cbd6904cd49b0b425e5edddd42c123b952725339b7388fb5a2debd72c04c1 SHA512 545d17286b937eb33b5fa14c36a480eea0146802f6c8a36e55987206b125bac55b25ab79a4c833ffa1fdcdbe56b2949acd5c8bdfd27c900bf64d5e738677ef4a
DIST cone-0.96.tar.bz2 3752115 BLAKE2B d4548083f86adc096534750e69db648d24fc5b643961041df04257d71f4e8af2c3456948f9227e652d2bdc80f65948bf8b543c3eba738187e17d6d9f5c424e28 SHA512 6bdc8ac1a8ae8345bb09eb03857cf5db2c55ac57e3f76726a7371fd763a4265f02dbda7bcbf03090d3004bc800a5bb42a328ead900ff71609246aaa4a314609e
DIST cone-1.0.tar.bz2 3793288 BLAKE2B e2c8aa91adfff77d3f0207a3caca5d13ebae8c9455402c296a98364708acd3d4138ea4642044b2dfe396eaef18c3b90ebf0ef3702bc73351a4317219a4c28863 SHA512 6fc30158cebed62b0598787d53e1936b50a32b6590266e93dbacbd63371d4fa8e43ffe95e0f4ee51991e2d892b26c1531b563203e45108815f05a091b7051161
73 changes: 73 additions & 0 deletions mail-client/cone/cone-1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit autotools

DESCRIPTION="CONE: COnsole News reader and Emailer"
HOMEPAGE="https://www.courier-mta.org/cone/"
SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="crypt fam gnutls idn ipv6 ldap spell"

RDEPEND="
dev-libs/libxml2
sys-libs/ncurses:0=
>=net-libs/courier-unicode-2
spell? ( app-text/aspell )
crypt? ( >=app-crypt/gnupg-1.0.4 )
fam? ( virtual/fam )
gnutls? (
net-libs/gnutls:0=
dev-libs/libgcrypt:0=
dev-libs/libgpg-error
)
!gnutls? ( >=dev-libs/openssl-0.9.6:0= )
idn? ( net-dns/libidn:0= )
ipv6? ( net-dns/libidn:0= )
ldap? ( net-nds/openldap )"
DEPEND="${RDEPEND}
dev-lang/perl"

PATCHES=( "${FILESDIR}"/${P}-no-spelling.patch )
DOCS=( AUTHORS ChangeLog INSTALL NEWS README )

src_prepare() {
default

# move local macro to m4 and run eautoreconf
mkdir "${S}"/m4 || die
sed -n -e '/# AC_PROG_SYSCONFTOOL/,+33 p' "${S}"/aclocal.m4 > m4/sysconftool.m4 || die
sed -i -e '/^SUBDIRS/i ACLOCAL_AMFLAGS = -I m4' "${S}"/Makefile.am || die

eautoreconf
}

src_configure() {
local myeconfargs=(
--with-notice=unicode
--with-spellcheck=$(usex spell aspell none)
$(use_with ldap ldapaddressbook)
$(use_with gnutls)
$(use_with idn libidn)
$(use_with ipv6)
)

econf "${myeconfargs[@]}"
}

src_install() {
default
emake DESTDIR="${D}" install-configure
}

pkg_postinst() {
if [[ ${REPLACING_VERSIONS} ]]; then
elog "See the \"Upgrading from version 0.96 and earlier\" section in"
elog "${EROOT}/usr/share/doc/${PF}/INSTALL for information on updating"
elog "older installs."
fi
}
46 changes: 46 additions & 0 deletions mail-client/cone/files/cone-1.0-no-spelling.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
Allow spellchecking support to be disabled.

--- cone-1.0/cone/configure.ac
+++ cone-1.0/cone/configure.ac
@@ -183,8 +183,10 @@
ALLSPELLOBJ='spellcheckerPspell.$(OBJEXT)'" $ALLSPELLOBJ"
fi

-AC_ARG_WITH(spellcheck, [ --with-spellcheck=pspell Use pspell for spell checking
- --with-spellcheck=aspell Use aspell for spell checking], [
+AC_ARG_WITH(spellcheck, [
+ --with-spellcheck=pspell Use pspell for spell checking
+ --with-spellcheck=aspell Use aspell for spell checking
+ --with-spellcheck=none Disable spell checking], [

case "$withval" in
pspell)
@@ -200,6 +202,10 @@
AC_MSG_ERROR(aspell library not found)
fi
;;
+none)
+ PSPELL="none"
+ ASPELL="none"
+ ;;
*)
AC_MSG_ERROR(Invalid --with-spellcheck option)
;;
@@ -232,10 +238,13 @@
SPELL_OBJ='spellcheckerPspell.$(OBJEXT)'
SPELL_LIB='-lpspell'
else
- AC_MSG_WARN(---------------------------------------------------------------)
- AC_MSG_WARN(Neither pspell nor aspell was found -- disabling spell checking)
- AC_MSG_WARN(---------------------------------------------------------------)
- sleep 5
+ if test "$ASPELL" != "none" && test "$PSPELL" != "none"
+ then
+ AC_MSG_WARN(---------------------------------------------------------------)
+ AC_MSG_WARN(Neither pspell nor aspell was found -- disabling spell checking)
+ AC_MSG_WARN(---------------------------------------------------------------)
+ sleep 5
+ fi
SPELL_OBJ='spellcheckerNone.$(OBJEXT)'
SPELL_LIB=''
fi

0 comments on commit 9370de7

Please sign in to comment.