Skip to content

Commit

Permalink
app-admin/sysstat: Version 11.6.2, 11.7.1.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
Jeroen Roovers committed Jan 15, 2018
1 parent a6fd701 commit 938766e
Show file tree
Hide file tree
Showing 3 changed files with 180 additions and 0 deletions.
2 changes: 2 additions & 0 deletions app-admin/sysstat/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,5 @@
DIST sysstat-11.4.0.tar.xz 343968 BLAKE2B e34da8cf0216f66fad3ade0ed40e8ec3b7641f7568ebcce5bc3122f888c90885ece346bf7f4f8e71e92435257ee5c6c0e5a89913c0e22a0ad28fa1018a73ea71 SHA512 4a5c81d75fdbc8dcaf80685f302688c39bd7143554e5a06cb324532ddb5180caac19b261182d5320f40b317bdb1e81664887acc7cedfeb5a95dc6ad37a898604
DIST sysstat-11.6.0.tar.xz 468528 BLAKE2B 512a1b9723ee6c96155fdff93c9aebff23901c13f92fd8352241851612c92ba15033e267aab6c4dd2a9fdf4f88a7f61c2e3af46f32aff5e9a60e52cb6ba3a066 SHA512 b54af1724777e20df54e9dac97b558abd4f669724234d4a62debbfa2dd5788020683ca8e47f95ea018feefd024abe2f930a91363b35ef490ddf69b7cf2d5df68
DIST sysstat-11.6.1.tar.xz 470584 BLAKE2B e9f85567743e6f0f2958afed40919c8bea7fc52f053fdd9bc7480e942e9a4a5620287f72cf26feedf4b74fc698331da2c305864b0037cf11e0617af2bc0da63b SHA512 55b3c361f7cda3d5efc0a42bef26d154c159a465ef45b56d2567f38aeec8c935c4e3b65a92eaf996abbf2d6a2604b2b8bba95741d707e8f387c9fadc05fafa93
DIST sysstat-11.6.2.tar.xz 471452 BLAKE2B da0647f25e9f4ec4d320f664d2124bd2bd3cc42a78201f2c86480afeb6525b20c158e1577321a0316134fca7e77c04b303829104ae59b0d790ab29bff09889ed SHA512 8f117601272d3d9b887c454d610d06f014b76902cdc68f6a11e693bdc58bb7ad1cac1006681774b3e6173f3cadd9b1f36e126d1d7501f0910b092d125d1c68ce
DIST sysstat-11.7.1.tar.xz 476916 BLAKE2B 016c5b6e2759af440ecd3bfc9b66f2b01988ef2e889090ab9156a7fdea02d9a3e6e47f6852ea699cf865d2ccf79d3152c70f0e23daf199edb936cb55a9a28fa7 SHA512 c0a8ce7a412e16d7d471cc0421a0f5586143ef8253f9a38872a63687bba50f98eebab5d501f92c4d085da51af56343628c8154cbd2d260b314153a17e23ff2e8
89 changes: 89 additions & 0 deletions app-admin/sysstat/sysstat-11.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,89 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit flag-o-matic multilib systemd toolchain-funcs

DESCRIPTION="System performance tools for Linux"
HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
SRC_URI="${HOMEPAGE}${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="debug nls lm_sensors selinux static"

CDEPEND="
nls? ( virtual/libintl )
lm_sensors? ( sys-apps/lm_sensors )
"
DEPEND="
${CDEPEND}
nls? ( sys-devel/gettext )
"
RDEPEND="
${CDEPEND}
selinux? ( sec-policy/selinux-sysstat )
"
PATCHES=(
"${FILESDIR}"/${PN}-10.0.4-flags.patch
"${FILESDIR}"/${PN}-11.0.4-cron.patch
)

SYSSTAT_FAKE_RC_DIR=Gentoo-does-not-use-rc.d

src_prepare() {
if use nls; then
strip-linguas -i nls/
local lingua pofile
for pofile in nls/*.po; do
lingua=${pofile/nls\/}
lingua=${lingua/.po}
if ! has ${lingua} ${LINGUAS}; then
rm "nls/${lingua}.po" || die
fi
done
fi

default
}

src_configure() {
tc-export AR
use static && append-ldflags -static

sa_lib_dir=/usr/$(get_libdir)/sa \
conf_dir=/etc \
rcdir=${SYSSTAT_FAKE_RC_DIR} \
econf \
$(use_enable debug debuginfo) \
$(use_enable lm_sensors sensors) \
$(use_enable nls) \
--enable-copy-only \
--enable-documentation \
--enable-install-cron \
--with-systemdsystemunitdir=$(systemd_get_systemunitdir)
}

src_compile() {
emake LFLAGS="${LDFLAGS}"
}

src_install() {
keepdir /var/log/sa

emake \
CHOWN=true \
DESTDIR="${D}" \
DOC_DIR=/usr/share/doc/${PF} \
MANGRPARG='' \
install

dodoc -r contrib/

rm -r "${D}/${SYSSTAT_FAKE_RC_DIR}" || die
newinitd "${FILESDIR}"/${PN}.init.d ${PN}
systemd_dounit ${PN}.service

rm -f "${D}"usr/share/doc/${PF}/COPYING
}
89 changes: 89 additions & 0 deletions app-admin/sysstat/sysstat-11.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,89 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit flag-o-matic multilib systemd toolchain-funcs

DESCRIPTION="System performance tools for Linux"
HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
SRC_URI="${HOMEPAGE}${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="debug nls lm_sensors selinux static"

CDEPEND="
nls? ( virtual/libintl )
lm_sensors? ( sys-apps/lm_sensors )
"
DEPEND="
${CDEPEND}
nls? ( sys-devel/gettext )
"
RDEPEND="
${CDEPEND}
selinux? ( sec-policy/selinux-sysstat )
"
PATCHES=(
"${FILESDIR}"/${PN}-10.0.4-flags.patch
"${FILESDIR}"/${PN}-11.0.4-cron.patch
)

SYSSTAT_FAKE_RC_DIR=Gentoo-does-not-use-rc.d

src_prepare() {
if use nls; then
strip-linguas -i nls/
local lingua pofile
for pofile in nls/*.po; do
lingua=${pofile/nls\/}
lingua=${lingua/.po}
if ! has ${lingua} ${LINGUAS}; then
rm "nls/${lingua}.po" || die
fi
done
fi

default
}

src_configure() {
tc-export AR
use static && append-ldflags -static

sa_lib_dir=/usr/$(get_libdir)/sa \
conf_dir=/etc \
rcdir=${SYSSTAT_FAKE_RC_DIR} \
econf \
$(use_enable debug debuginfo) \
$(use_enable lm_sensors sensors) \
$(use_enable nls) \
--enable-copy-only \
--enable-documentation \
--enable-install-cron \
--with-systemdsystemunitdir=$(systemd_get_systemunitdir)
}

src_compile() {
emake LFLAGS="${LDFLAGS}"
}

src_install() {
keepdir /var/log/sa

emake \
CHOWN=true \
DESTDIR="${D}" \
DOC_DIR=/usr/share/doc/${PF} \
MANGRPARG='' \
install

dodoc -r contrib/

rm -r "${D}/${SYSSTAT_FAKE_RC_DIR}" || die
newinitd "${FILESDIR}"/${PN}.init.d ${PN}
systemd_dounit ${PN}.service

rm -f "${D}"usr/share/doc/${PF}/COPYING
}

0 comments on commit 938766e

Please sign in to comment.