Skip to content

Commit

Permalink
app-i18n/freewnn: update to EAPI 6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
hattya committed Jul 18, 2017
1 parent 404d111 commit 93c8084
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 43 deletions.
63 changes: 27 additions & 36 deletions app-i18n/freewnn/freewnn-1.1.1_alpha22.ebuild
Original file line number Diff line number Diff line change
@@ -1,60 +1,51 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit eutils
EAPI="6"

MY_P="FreeWnn-${PV/_alpha/-a0}"

DESCRIPTION="Network-Extensible Kana-to-Kanji Conversion System"
HOMEPAGE="http://freewnn.sourceforge.jp/
http://www.freewnn.org/"
SRC_URI="mirror://sourceforge.jp/freewnn/59257/${MY_P}.tar.bz2"
HOMEPAGE="http://freewnn.sourceforge.jp/ http://www.freewnn.org/"
SRC_URI="mirror://sourceforge.jp/${PN}/59257/${MY_P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~arm64 hppa ia64 ppc ppc64 sparc x86"
IUSE="X ipv6"

DEPEND="X? ( x11-libs/libX11 x11-libs/libXmu x11-libs/libXt )"
RDEPEND="${DEPEND}"
IUSE="ipv6"

S="${WORKDIR}/${MY_P}"

src_prepare() {
#Change WNNOWNER to root so we don't need to add wnn user
# and disable stripping of binary files
sed -i -e "s/WNNOWNER = wnn/WNNOWNER = root/" \
-e "s/@INSTPGMFLAGS@//" makerule.mk.in \
-e "s/@LN_S@/ln -sf/" || die

#bug #318593
PATCHES=( "${FILESDIR}"/${P}-parallel-build.patch )
DOCS="ChangeLog* CONTRIBUTORS"

epatch "${FILESDIR}"/${P}-parallel-build.patch #517916

# 542534
sed -i -e "s/egrep -v/egrep -av/" kWnn/kdic/Makefile.in \
cWnn/tdic/Makefile.in cWnn/cdic/Makefile.in \
Wnn/pubdicplus/Makefile.in || die
src_prepare() {
default

sed -i \
-e "s/WNNOWNER = wnn/WNNOWNER = root/" \
-e "s/@INSTPGMFLAGS@//" \
makerule.mk.in

# bug #542534
sed -i \
-e "s/egrep -v/egrep -av/" \
PubdicPlus/Makefile.in \
Wnn/pubdicplus/Makefile.in \
cWnn/[ct]dic/Makefile.in \
kWnn/kdic/Makefile.in
}

src_configure() {
econf \
$(use_with ipv6) \
--disable-cWnn \
--disable-kWnn \
--without-termcap \
$(use_with X x) \
$(use_with ipv6)
--disable-kWnn
}

src_install() {
# install executables, libs ,dictionaries
emake DESTDIR="${ED}" install || die
# install man pages
emake DESTDIR="${ED}" install.man || die
# install docs
dodoc ChangeLog* CONTRIBUTORS
# install rc script
newinitd "${FILESDIR}"/freewnn.initd freewnn
emake DESTDIR="${D}" install install.man
einstalldocs

newinitd "${FILESDIR}"/${PN}.initd ${PN}
}
14 changes: 7 additions & 7 deletions app-i18n/freewnn/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Cjk</name>
</maintainer>
<upstream>
<remote-id type="sourceforge-jp">freewnn</remote-id>
</upstream>
<maintainer type="project">
<email>[email protected]</email>
<name>Cjk</name>
</maintainer>
<upstream>
<remote-id type="sourceforge-jp">freewnn</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 93c8084

Please sign in to comment.