Skip to content

Commit

Permalink
app-emulation/docker-machine: version bump to 0.8.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
zmedico committed Oct 26, 2016
1 parent 54e1f88 commit 93fd907
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/docker-machine/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST docker-machine-0.7.0.tar.gz 3173248 SHA256 b36152f719a453327ab071b7f9fef76a5b3264b7944c14ad20c79f7535114e4a SHA512 312c6222ae5bb82e9236021502cc8aa486b76dc4f6773729a5887def2fcf06499fa62cebc79ba9c91f88685411d0e88fa0d0ce218382a748afdabadbee8cc4fd WHIRLPOOL 236070fade6887221979ea3b3aa0a62d734fecaa800ab89a0242130355d0d196d064a764bc1abaafc47a193b9cfc24caef6067eca68e8e4bacab929d7ca7a137
DIST docker-machine-0.8.2.tar.gz 2928577 SHA256 6ca75b2995f57505901da2f45ce422c782b73d89054cc10868100b3404ccfd05 SHA512 3fa683f74466e30616495b8e635e28be0c7557e17940bc4f3f8598a755463b5ae75e64405281325e2028aee5a3e06744329d9bf0a7b6ade200f3d3c51ba2fe80 WHIRLPOOL 37d9ddd2a946ee890bb771b304be692385e0ef1f53ef8ed100f2860e7cab7b825093a2d7b4c3bfa8b78193df1ab7ec9d16817aef1985a48ae1b97b666051cf96
42 changes: 42 additions & 0 deletions app-emulation/docker-machine/docker-machine-0.8.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

EGO_PN=github.com/docker/machine/...

if [[ ${PV} = *9999* ]]; then
inherit golang-vcs
else
KEYWORDS="~amd64"
EGIT_COMMIT="v${PV}"
SRC_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
inherit golang-vcs-snapshot
fi
inherit golang-build

DESCRIPTION="Machine management for a container-centric world"
HOMEPAGE="https://docs.docker.com/machine/ "
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
RESTRICT="test"
DEPEND=">=dev-lang/go-1.7:="
RDEPEND=""
S=${WORKDIR}/${P}/src/${EGO_PN%/*}

src_prepare() {
eapply_user
# don't pre-strip binaries
sed -e 's|\(GO_LDFLAGS := $(GO_LDFLAGS) -w\) -s|\1|' -i mk/main.mk ||die
}

src_compile() {
GOPATH="${WORKDIR}/${P}" emake build || die
}

src_install() {
dobin bin/*
dodoc CHANGELOG.md CONTRIBUTING.md README.md ROADMAP.md
}

0 comments on commit 93fd907

Please sign in to comment.