Skip to content

Commit

Permalink
app-emulation/rkt: version bump to 1.17.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
zmedico committed Oct 17, 2016
1 parent 7900bea commit 9518a56
Show file tree
Hide file tree
Showing 2 changed files with 248 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/rkt/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,5 +4,6 @@ DIST qemu-2.6.1.tar.bz2 25762855 SHA256 4942fd1b6ee31f2f55ffc2201dd7397e6b9c55a2
DIST rkt-1.14.0.tar.gz 2947502 SHA256 2458783023c561358c59600accb58ccfe335535931a58da988d70893a1c5a5e7 SHA512 4e082f0293047d133b031b6fd95e34fc86b7b2ca133ea56709cded5cd0c454e56bb5dd7209bc7add56812142495430c457d9094a8cda1c0079085822ff6e1c94 WHIRLPOOL 09837fc509cce2609bd87ae1185ce6c1e85e13888ab8106aab1725e8e3232486330e4152db8deb77dbc2c419d176a8f1c6df6d44d9a2808aefd62e58082a0353
DIST rkt-1.15.0.tar.gz 3018468 SHA256 3efd0dc96c8783d5b378862c7239f733863a181bb3148f3b2e8e10023df06e01 SHA512 4f35eee5f689c8a36760c784d079751cfd0224c20c60f915ab1a550040739ec9290ba9e481e1679f67044400f8d3a60588b6d6d6cdfbbc1f3093c7010d35d290 WHIRLPOOL a07cbd102280c911ba79748931f841d2d5e28407225f2b1d48604b1d0e1c3d81c6488c40e2ef4ef571b628f1766f9aa1e5208138ca963c06e7b3b9226f5b6b6c
DIST rkt-1.16.0.tar.gz 3028683 SHA256 8c7bb07217b68e153d54e45646072fd267ee1ee88a410887f2d8f75eb4752e89 SHA512 b270c8340ca5a22c48209f9d8fa6c55e8cd1b8e238117c4e3a9e5d4fff04bde194e53d10112dd429f5f1c36e0395ca42ae6bd12fd5ebff68a50d3546a1a8d31d WHIRLPOOL d532cfac6347d675b5cbf96e9c38d4cdbb4f4fbd493474567755ff3560c31b8edc59c2cf83f51953ac56c81f7f1af84c625cf1c7f571a48275b6df3dd8f171f3
DIST rkt-1.17.0.tar.gz 3031700 SHA256 9cebd53d14f37fdfae6f2cb4114d472399773d14f2b8cbff6ea60dcb11a57604 SHA512 ee7346391a386fb3bbd52b751d2814700d5fde5c616b0dd76c4bb0f78f9d5e9d7f9ee574a2feee121ccee7f0a900e76b77428f3f6de8c6b6cb3bd324d763b1f0 WHIRLPOOL dbf7a8ad99e3e0ae40be6ac36e6794afe7d5f9a07def1bb4f88ada9abe13e2b2af3e6ae44d7850b228d16249c5fc9b72083271bc74cc56f3c4de20e35092f903
DIST rkt-pxe-1151.0.0.img 243335216 SHA256 6f08697bea372af916a150f9846110e8855305653e5582b2c2ea04f14253e5c8 SHA512 fe7c4ec8cb4d11ba704b9f78c43557a374fda70dbfd7c3f4f9e768cf5ae365aab7a1fee8d51e19bbad6809ad4cdfe4eed60e5cdb6babd869a3a91b503b7256e8 WHIRLPOOL 92f8a65a9c50c11fa9c56acee53dd5623dd186664f44c6517bac4ee5be6a9dd2a9141ef522d978cc5b282c6638e17bf7b3559d68d6ea6c0752821799c0c88a5c
DIST systemd-231.tar.gz 4381464 SHA256 899733ad6c157cedbb89aec4efe3bc824dcfd65a1d6f6bebc7b043f7924e39b4 SHA512 199fa33a0494d1d15f7fe3c796fe14913ad386766571d4d3fbb1cb1c446e04f6d06a965213be4c594a7183e810fc2fd4804fe14f64f21b0a1278b717889811c6 WHIRLPOOL 7779291e9fb9873cb1773b8583cf6d4b7dec837363ea89c4a73c1e397a76752b66f8b57d8fc4d9cef768cc1855b5e325ad88a8a69eb5380aa924e0a6dead41b1
247 changes: 247 additions & 0 deletions app-emulation/rkt/rkt-1.17.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,247 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit bash-completion-r1 autotools flag-o-matic systemd toolchain-funcs user

KEYWORDS="~amd64"

PXE_VERSION="1151.0.0"
PXE_SYSTEMD_VERSION="v231"
KVM_LINUX_VERSION="4.3.1"
KVMTOOL_VERSION="d62653e177597251c24494a6dda60acd6d846671"
QEMU_VERSION="v2.6.1"
PXE_URI="http://alpha.release.core-os.net/amd64-usr/${PXE_VERSION}/coreos_production_pxe_image.cpio.gz"
PXE_FILE="${PN}-pxe-${PXE_VERSION}.img"

SRC_URI_KVM="mirror://kernel/linux/kernel/v4.x/linux-${KVM_LINUX_VERSION}.tar.xz
${PXE_URI} -> ${PXE_FILE}
"

SRC_URI="https://github.com/coreos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
rkt_stage1_coreos? ( $PXE_URI -> $PXE_FILE )
rkt_stage1_kvm_lkvm? (
https://kernel.googlesource.com/pub/scm/linux/kernel/git/will/kvmtool/+archive/${KVMTOOL_VERSION}.tar.gz -> kvmtool-${KVMTOOL_VERSION}.tar.gz
${SRC_URI_KVM}
)
rkt_stage1_kvm_qemu? (
http://wiki.qemu-project.org/download/qemu-${QEMU_VERSION#v}.tar.bz2
${SRC_URI_KVM}
)
rkt_stage1_src? ( https://github.com/systemd/systemd/archive/${PXE_SYSTEMD_VERSION}.tar.gz -> systemd-${PXE_SYSTEMD_VERSION#v}.tar.gz )"

DESCRIPTION="rkt is an App Container runtime for Linux"
HOMEPAGE="https://github.com/coreos/rkt"

LICENSE="Apache-2.0"
SLOT="0"
# The rkt_stage1_kvm flag has been replaced by the rkt_stage1_kvm_lkvm and rkt_stage1_kvm_qemu flags
IUSE="doc examples +rkt_stage1_coreos +rkt_stage1_fly rkt_stage1_host rkt_stage1_kvm rkt_stage1_kvm_lkvm rkt_stage1_kvm_qemu rkt_stage1_src +actool systemd"
REQUIRED_USE="|| ( rkt_stage1_coreos rkt_stage1_fly rkt_stage1_host rkt_stage1_kvm_lkvm rkt_stage1_kvm_qemu rkt_stage1_src ) rkt_stage1_host? ( systemd ) !rkt_stage1_kvm"

DEPEND=">=dev-lang/go-1.5
app-arch/cpio
app-crypt/trousers
sys-fs/squashfs-tools
dev-perl/Capture-Tiny
rkt_stage1_src? ( >=sys-apps/util-linux-2.27 )
rkt_stage1_kvm_qemu? (
sys-libs/libcap[static-libs(+)]
>=x11-libs/pixman-0.28.0[static-libs(+)]
)"

RDEPEND="!app-emulation/rocket
rkt_stage1_host? ( systemd? (
>=sys-apps/systemd-222
app-shells/bash:0
) )"

BUILDDIR="build-${P}"
STAGE1_DEFAULT_LOCATION="/usr/share/rkt/stage1.aci"

pkg_setup() {
enewgroup rkt-admin
enewgroup rkt
}

src_unpack() {
local x
for x in ${A}; do
case ${x} in
*.img|linux-*) continue ;;
kvmtool-*)
mkdir kvmtool || die
pushd kvmtool >/dev/null || die
unpack ${x}
popd >/dev/null || die
;;
*)
unpack ${x}
esac
done
}

src_prepare() {
eapply_user

# avoid sdjournal include for bug 595874
if ! use systemd; then
sed -e "s/^\\(LOCAL_DIST_SRC_FILTER := .*\\)'$/\\1|api_service'/" \
-i rkt/rkt.mk || die
fi

sed -e 's|^RKT_REQ_PROG(\[GIT\],.*|#\0|' -i configure.ac || die

# disable git fetch of systemd
sed -e 's~^include makelib/git.mk$~'\
'ifneq ($(wildcard $(RKT_STAGE1_SYSTEMD_SRC)),)\n\n'\
'get_systemd_sources: | $(UFS_SYSTEMDDIR)\n'\
'\tmv "$(RKT_STAGE1_SYSTEMD_SRC)" "$(UFS_SYSTEMD_SRCDIR)"\n\n'\
'$(UFS_SYSTEMD_CONFIGURE): get_systemd_sources\n\n'\
'else ifneq ($(wildcard $(UFS_SYSTEMD_SRCDIR)),)\n\n'\
'else\n'\
'\t\0\n'\
'endif~' -i stage1/usr_from_src/usr_from_src.mk || die

# disable git fetch of kvmtool
sed -e 's~^include makelib/git.mk$~'\
'ifneq ($(wildcard $(shell echo "$${WORKDIR}/kvmtool")),)\n\n'\
'$(call forward-vars, get_lkvm_sources, LKVM_SRCDIR)\n'\
'get_lkvm_sources: | $(LKVM_TMPDIR)\n'\
'\tmv "$${WORKDIR}/kvmtool" "$(LKVM_SRCDIR)"\n\n'\
'$(LKVM_PATCH_STAMP): get_lkvm_sources\n\n'\
'else ifneq ($(wildcard $(LKVM_SRCDIR)),)\n\n'\
'else\n'\
'\t\0\n'\
'endif~' -i stage1/usr_from_kvm/lkvm.mk || die

# disable git fetch of qemu
sed -e 's~^include makelib/git.mk$~'\
'ifneq ($(wildcard $(shell echo "$${WORKDIR}/qemu-'${QEMU_VERSION#v}'")),)\n\n'\
'$(call forward-vars, get_qemu_sources, QEMU_SRCDIR)\n'\
'get_qemu_sources: | $(QEMU_TMPDIR)\n'\
'\tmv "$${WORKDIR}/qemu-'${QEMU_VERSION#v}'" "$(QEMU_SRCDIR)"\n\n'\
'$(QEMU_CLONE_STAMP): get_qemu_sources\n\n'\
'else ifneq ($(wildcard $(QEMU_SRCDIR)),)\n\n'\
'else\n'\
'\t\0\n'\
'endif~' \
-e 's|QEMU_CONFIGURATION_OPTS :=|\0 --disable-opengl|' \
-i stage1/usr_from_kvm/qemu.mk || die

# disable fetch of kernel sources
sed -e 's|wget .*|ln -s "$${DISTDIR}/linux-'${KVM_LINUX_VERSION}'.tar.xz" "$@"|' \
-i stage1/usr_from_kvm/kernel.mk || die

if use rkt_stage1_host; then
# Make systemdUnitsPath consistent with host
sed -e 's|\(systemdUnitsPath := \).*|\1"'$(systemd_get_systemunitdir)'"|' \
-i stage1/init/init.go || die
fi

eautoreconf
}

src_configure() {
local flavors hypervisors myeconfargs=(
--with-stage1-default-images-directory="/usr/share/rkt"
--with-stage1-default-location="${STAGE1_DEFAULT_LOCATION}"
)

use systemd || myeconfargs+=( --enable-sdjournal=no )

# enable flavors (first is default)
use rkt_stage1_host && flavors+=",host"
use rkt_stage1_src && flavors+=",src"
use rkt_stage1_coreos && flavors+=",coreos"
use rkt_stage1_fly && flavors+=",fly"
{ use rkt_stage1_kvm_lkvm || use rkt_stage1_kvm_qemu; } && flavors+=",kvm"
myeconfargs+=( --with-stage1-flavors="${flavors#,}" )

if use rkt_stage1_src; then
myeconfargs+=(
--with-stage1-systemd-version=${PXE_SYSTEMD_VERSION}
--with-stage1-systemd-src="${WORKDIR}/systemd-${PXE_SYSTEMD_VERSION#v}"
)
fi

if use rkt_stage1_coreos || use rkt_stage1_kvm_lkvm || use rkt_stage1_kvm_qemu; then
myeconfargs+=(
--with-coreos-local-pxe-image-path="${DISTDIR}/${PXE_FILE}"
--with-coreos-local-pxe-image-systemd-version="${PXE_SYSTEMD_VERSION}"
)
fi

if use rkt_stage1_kvm_lkvm || use rkt_stage1_kvm_qemu; then
use rkt_stage1_kvm_lkvm && hypervisors+=",lkvm"
use rkt_stage1_kvm_qemu && hypervisors+=",qemu"
myeconfargs+=( --with-stage1-kvm-hypervisors="${hypervisors#,}" )
fi

# Go's 6l linker does not support PIE, disable so cgo binaries
# which use 6l+gcc for linking can be built correctly.
if gcc-specs-pie; then
append-ldflags -nopie
fi

export CC=$(tc-getCC)
export CGO_ENABLED=1
export CGO_CFLAGS="${CFLAGS}"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export BUILDDIR

econf "${myeconfargs[@]}"
}

src_compile() {
local arch=${ARCH}
case ${arch} in
amd64) arch=x86_64;;
esac
ARCH=${arch} emake
ARCH=${arch} emake bash-completion
}

src_install() {
dodoc README.md
use doc && dodoc -r Documentation
use examples && dodoc -r examples
use actool && dobin "${S}/${BUILDDIR}/tools/actool"

dobin "${S}/${BUILDDIR}/target/bin/rkt"

insinto /usr/share/rkt
doins "${S}/${BUILDDIR}/target/bin/"*.aci

# create symlink for default stage1 image path
if use rkt_stage1_host; then
dosym stage1-host.aci "${STAGE1_DEFAULT_LOCATION}"
elif use rkt_stage1_src; then
dosym stage1-src.aci "${STAGE1_DEFAULT_LOCATION}"
elif use rkt_stage1_coreos; then
dosym stage1-coreos.aci "${STAGE1_DEFAULT_LOCATION}"
elif use rkt_stage1_fly; then
dosym stage1-fly.aci "${STAGE1_DEFAULT_LOCATION}"
elif use rkt_stage1_kvm_lkvm; then
dosym stage1-kvm-lkvm.aci "${STAGE1_DEFAULT_LOCATION}"
elif use rkt_stage1_kvm_qemu; then
dosym stage1-kvm-qemu.aci "${STAGE1_DEFAULT_LOCATION}"
fi

systemd_dounit "${S}"/dist/init/systemd/*.service \
"${S}"/dist/init/systemd/*.timer \
"${S}"/dist/init/systemd/*.socket

insinto /usr/lib/tmpfiles.d
doins "${S}"/dist/init/systemd/tmpfiles.d/*

newbashcomp "${S}"/dist/bash_completion/rkt.bash rkt

keepdir /etc/${PN}
fowners :rkt-admin /etc/${PN}
fperms 2775 /etc/${PN}
}

0 comments on commit 9518a56

Please sign in to comment.