Skip to content

Commit

Permalink
app-admin/lastpass-cli: bump to v1.3.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Göktürk Yüksek <[email protected]>
  • Loading branch information
gktrk committed Mar 27, 2019
1 parent 291e2cf commit 952fdf0
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/lastpass-cli/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST lastpass-cli-1.3.1.tar.gz 114843 BLAKE2B 7983d4090092ef3443d8c502d157934fa2384426f0be22c796795cdf664be3ba396f64daa81cdf896cb6901d4063f93e54b62cda4349b14fa4d312a21c5bb76d SHA512 092d28dc459719e662fbb2c5e92e8cc75be108aa9d7b62569ee44cb34dd9588e78151fdc5ad114c30e8de21c0b8803edc41db9295548c7cbfe6e537c9a52aad2
DIST lastpass-cli-1.3.2.tar.gz 116399 BLAKE2B d00ab9443935b90eab7337702a52e0ed2e7f2e67c20ed6764f72e25ae123e0420013aa9220ece8a57b7e3bbe2f243ff56bd054fecdbd064f086536bc5eaf0d88 SHA512 b293e86d70988aa5860a94fdc2bc65341bb253d2423c8f745730419400adc91ff860017d35657d283458c477c2385ff2532b8aefa752f886b207da8d10bf9018
DIST lastpass-cli-man-1.3.1.tar.xz 5700 BLAKE2B 736ab71ad55cfcb657c727f3dc9dc15775dab1a0232d1ffc51b8794e49911531c96a841b4a5ac0b31f0516cd7aa54027ac7d0eb096816730cdfd192c04d99449 SHA512 e60807683ecd681b3937ef447d3e6a487d25418fe99f51ba99e54bf643c5254dd18427a03e7f035198ef34ff578bbb6116baf04eb554f54d85e7d059b6bfed7e
65 changes: 65 additions & 0 deletions app-admin/lastpass-cli/lastpass-cli-1.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

CMAKE_WARN_UNUSED_CLI=no
inherit cmake-utils bash-completion-r1

DESCRIPTION="Interfaces with LastPass.com from the command line."
HOMEPAGE="https://github.com/lastpass/lastpass-cli"
SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://dev.gentoo.org/~gokturk/distfiles/app-admin/lastpass-cli/${PN}-man-1.3.1.tar.xz"

SLOT="0"
LICENSE="GPL-2+ GPL-2+-with-openssl-exception"
KEYWORDS="~amd64 ~x86"
IUSE="libressl X +pinentry test"

RDEPEND="
X? ( || ( x11-misc/xclip x11-misc/xsel ) )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
net-misc/curl
dev-libs/libxml2
pinentry? ( app-crypt/pinentry )
"
DEPEND="${RDEPEND}
virtual/pkgconfig
"

src_configure() {
local mycmakeargs=(
-DBASH_COMPLETION_COMPLETIONSDIR="$(get_bashcompdir)"
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile all $(usex test lpass-test '')
}

src_install() {
cmake-utils_src_install install

doman "${WORKDIR}"/man/lpass.1

# Version 1.3.2 uses automagic detection for bashcomp
# To preserve backwards compatibility, we unconditionally
# install the completion file
newbashcomp contrib/lpass_bash_completion lpass
}

src_test() {
local myctestargs=(
-j1 # Parallel tests fail
)

# The path to lpass-test is hardcoded to "${S}"/build/lpass-test
# which is incorrect for our out-of-source build
sed -e "s|TEST_LPASS=.*|TEST_LPASS=\"${BUILD_DIR}/lpass-test\"|" \
-i "${S}"/test/include.sh || die

cmake-utils_src_test
}

0 comments on commit 952fdf0

Please sign in to comment.