Skip to content

Commit

Permalink
dev-ruby/travis: drop unused typhoeus dep
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Nov 26, 2021
1 parent 449f07a commit 954d757
Showing 1 changed file with 60 additions and 0 deletions.
60 changes: 60 additions & 0 deletions dev-ruby/travis/travis-1.10.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
USE_RUBY="ruby26"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_EXTRAINSTALL="assets"

inherit bash-completion-r1 ruby-fakegem

DESCRIPTION="Travis CI Client (CLI and Ruby library)"
HOMEPAGE="https://github.com/travis-ci/travis.rb"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
#RESTRICT="test"

DEPEND+="test? ( dev-vcs/git )"
RDEPEND+="dev-vcs/git"

ruby_add_bdepend "
test? ( >dev-ruby/rack-test-0.6 dev-ruby/rspec-its )
>dev-ruby/sinatra-1.3
"

ruby_add_rdepend "
dev-ruby/faraday:1
dev-ruby/faraday_middleware:1
>=dev-ruby/gh-0.17
dev-ruby/highline:2
>=dev-ruby/json-2.3:2
>=dev-ruby/launchy-2.1
>dev-ruby/pusher-client-0.4
"

all_ruby_prepare() {
if use test ; then
git init --quiet . || die
git remote add origin "${HOMEPAGE}" || die
touch .travis.yml || die
fi

# Remove failing spec where cause is not fully clear.
# May be related to highline compatibility issues.
rm spec/cli/login_spec.rb || die

# Remove failing specs where $params keys are reset somewhere.
rm -f spec/cli/{cancel,restart}_spec.rb || die

sed -i -e 's/json_pure/json/' ../metadata || die
}

all_ruby_install() {
all_fakegem_install

newbashcomp "assets/travis.sh" "travis"
}

0 comments on commit 954d757

Please sign in to comment.