Skip to content

Commit

Permalink
games-fps/transfusion-bin: port to EAPI 7, missing deps, silence QA w…
Browse files Browse the repository at this point in the history
…arnings

Closes: https://bugs.gentoo.org/724810
Closes: https://bugs.gentoo.org/724832
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 10, 2021
1 parent b6aa0da commit 9587b31
Showing 1 changed file with 18 additions and 10 deletions.
28 changes: 18 additions & 10 deletions games-fps/transfusion-bin/transfusion-bin-1.01-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,27 +1,35 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils
EAPI=7

inherit desktop wrapper

MY_PN="${PN/-bin/}"
DESCRIPTION="Blood remake"
HOMEPAGE="https://www.transfusion-game.com/"
SRC_URI="mirror://sourceforge/blood/${MY_PN}-1.0-linux.i386.zip
mirror://sourceforge/blood/${MY_PN}-patch-${PV}-linux.i386.zip
mirror://gentoo/${MY_PN}.png"
S="${WORKDIR}/${MY_PN}"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE=""
RESTRICT="strip"

RDEPEND="sys-libs/glibc"
DEPEND="${RDEPEND}
app-arch/unzip"
RDEPEND="
sys-libs/glibc
x11-libs/libX11
x11-libs/libXext
"
DEPEND="${RDEPEND}"
BDEPEND="app-arch/unzip"

S="${WORKDIR}/${MY_PN}"
QA_PREBUILT="
opt/transfusion/transfusion-dedicated
opt/transfusion/transfusion-glx
"

dir="/opt/${MY_PN}"
Ddir="${D}/${dir}"
Expand All @@ -32,14 +40,14 @@ src_install() {
HTML_DOCS="${MY_PN}/doc/*.html" einstalldocs

#...then mass copy everything to the install dir...
dodir "${dir}"
dodir ${dir}
cp -R * "${Ddir}" || die

# ...and remove the docs since we don't need them installed twice.
rm -rf \
"${Ddir}"/${MY_PN}/doc \
"${Ddir}"/qw/*txt \
"${Ddir}"/${MY_PN}/*txt
"${Ddir}"/${MY_PN}/*txt || die

doicon "${DISTDIR}"/${MY_PN}.png
make_wrapper ${MY_PN} ./${MY_PN}-glx "${dir}" "${dir}"
Expand Down

0 comments on commit 9587b31

Please sign in to comment.