Skip to content

Commit

Permalink
dev-ros/interval_intersection: Initial import. Ebuild by me.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
  • Loading branch information
aballier committed Oct 11, 2015
1 parent 6cbb969 commit 95a6f20
Show file tree
Hide file tree
Showing 4 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ros/interval_intersection/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST calibration-0.10.13.tar.gz 112305 SHA256 935755f9428e6b998d1a9ce10fcf11f3c119953ebe0b65eda855804ec8b8aea8 SHA512 95b5ea28428ea9726b6b1a8f24cd4c7cb84992e680761357c1a13dd92c362149a0a6104f6a44dbefad503db1a9c7a53135d9756b1ceea3a739b1baa14f9474eb WHIRLPOOL 94423d70268b053daee1da1b324582d2f8316c6feaa5c9291715b1861520cb2e67654daaa2156e8d15cd59ecb566bdd3cb76d42c7202b85680888bac3532002c
30 changes: 30 additions & 0 deletions dev-ros/interval_intersection/interval_intersection-0.10.13.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
ROS_REPO_URI="https://github.com/ros-perception/calibration"
KEYWORDS="~amd64 ~arm"
PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
CATKIN_HAS_MESSAGES=yes
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"

inherit ros-catkin

DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
LICENSE="BSD"
SLOT="0"
IUSE=""

RDEPEND="
dev-libs/boost:=[threads]
dev-ros/actionlib
dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/rosconsole
dev-ros/roscpp
dev-ros/roscpp_serialization
dev-ros/rostime
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
30 changes: 30 additions & 0 deletions dev-ros/interval_intersection/interval_intersection-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
ROS_REPO_URI="https://github.com/ros-perception/calibration"
KEYWORDS="~amd64 ~arm"
PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
CATKIN_HAS_MESSAGES=yes
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"

inherit ros-catkin

DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
LICENSE="BSD"
SLOT="0"
IUSE=""

RDEPEND="
dev-libs/boost:=[threads]
dev-ros/actionlib
dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/rosconsole
dev-ros/roscpp
dev-ros/roscpp_serialization
dev-ros/rostime
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
5 changes: 5 additions & 0 deletions dev-ros/interval_intersection/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>ros</herd>
</pkgmetadata>

0 comments on commit 95a6f20

Please sign in to comment.