Skip to content

Commit

Permalink
app-admin/keepass: Version bump to 2.40
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.49, Repoman-2.3.10
  • Loading branch information
mrueg committed Sep 16, 2018
1 parent deee54f commit 9766e86
Show file tree
Hide file tree
Showing 2 changed files with 112 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/keepass/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST KeePass-2.38-Source.zip 5091900 BLAKE2B 22e3f7046984204a3e0c4a1c6d8303661048bc0fee4bcdb7999b521d0ed6e5463d89044d2897cfec0c932349cc80a7b43d4c8dfbceb4f2e88041c642e0c0d231 SHA512 42fa7274874d4858da360a6772eb25adbf3a6dafe375093459d9a25903d8c159360ea722e969fe8b330bccf62ee5d381e131bd0ba075445932d8019eee19bf20
DIST KeePass-2.39.1-Source.zip 5109228 BLAKE2B 0b1214ac70d3d615e029c89abe63176f31e29a3fb800d84b6102220d2d39ebba848e3100e85e6f3d5cd4965461c68798ba880d5b229e8f8e6a20b0d65c2c632c SHA512 9f2b5f6c86b00932f132f8eea24fc35f08c217ed3feb047afe585592761f5297b76140c3154fb519dc5c9137718227a0bc4b6a45d22d1eb0ac95d08c73a70314
DIST KeePass-2.40-Source.zip 5136918 BLAKE2B 7b5071cbe3bc5f20450a094a4b8969e2e25f6bba27d88ee5c2c25f2706ed3cf18e721ba53ff54c78db6ea1e167cef1108611fc8253a9d6e19eb3f9d1f3317c73 SHA512 222f7e7ef65be8b0d75baa0a6e871d5edad1b570b64f261405b843d7387ec1faeb4138afb8b31934d70eebe0add297681028cb4f3acfcbe4f518c763fe6c0145
111 changes: 111 additions & 0 deletions app-admin/keepass/keepass-2.40.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,111 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils gnome2-utils xdg-utils

MY_PN="KeePass"
DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
HOMEPAGE="https://keepass.info/"
SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="aot"

COMMON_DEPEND="dev-lang/mono"
DEPEND="${COMMON_DEPEND}
app-arch/unzip
"
RDEPEND="${COMMON_DEPEND}
dev-dotnet/libgdiplus[cairo]
"

S="${WORKDIR}"
PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )

src_prepare() {
# KeePass looks for some XSL files in the same folder as the executable,
# we prefer to have it in /usr/share/KeePass. Apply patch using base function.
# This XSL file will not be upstreamed since the KeePass creator said that
# including this patch would break the Portable USB version of KeePass
# (which keeps/looks for xsl files in its own folder)
default

# Switch into build dir so the mono prepration script works correctly
pushd Build || die
source PrepMonoDev.sh || die
popd || die
}

src_compile() {
# Build with Release target
xbuild /target:KeePass /property:Configuration=Release || die

# Run Ahead Of Time compiler on the binary
if use aot; then
cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
fi
}

src_install() {
# Wrapper script to launch mono
make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"

# Some XSL files
insinto "/usr/share/${PN}/XSL"
doins Ext/XSL/*

insinto "/usr/$(get_libdir)/${PN}"
exeinto "/usr/$(get_libdir)/${PN}"

doins Ext/KeePass.exe.config

# Default configuration, simply says to use user-specific configuration
doins Ext/KeePass.config.xml

# The actual executable
doexe Build/KeePass/Release/KeePass.exe

# Copy the AOT compilation result
if use aot; then
doexe Build/KeePass/Release/KeePass.exe.so
fi

# Prepare the icons
newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"

# Create a desktop entry and associate it with the KeePass mime type
make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;"

# MIME descriptor for .kdbx files
insinto /usr/share/mime/packages
doins "${FILESDIR}/${PN}.xml"

# sed, because patching this really sucks
sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass" || die
}

pkg_postinst() {
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update

if ! has_version x11-misc/xdotool ; then
elog "Optional dependencies:"
elog " x11-misc/xdotool (enables autotype/autofill)"
fi

elog "Some systems may experience issues with copy and paste operations."
elog "If you encounter this, please install x11-misc/xsel."
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

0 comments on commit 9766e86

Please sign in to comment.