Skip to content

Commit

Permalink
net-dns/knot: bump to 3.0.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.8, Repoman-3.0.2
Signed-off-by: Pierre-Olivier Mercier <[email protected]>
Signed-off-by: Aaron Bauman <[email protected]>
  • Loading branch information
nemunaire authored and FuzzyGophers committed Nov 13, 2020
1 parent 8520016 commit 9797457
Show file tree
Hide file tree
Showing 2 changed files with 103 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-dns/knot/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST knot-2.9.7.tar.xz 1188904 BLAKE2B f20355f211db316a1e39321a1200130e2af4e895eff92eca36c93d5b8f78fcd9dd8fa1ec25edf7a0fa9bae4aa2a92b2fca890be1da4134b894792235de0b546e SHA512 399b48491c000aa3f16b87b1e313f2ea5fe369d19da0c81222ed43ca155bf4d4d1a561ef84bc08844eaf24d3dd07ded9a6ec3d831dd5f6ffb174ae773ae12931
DIST knot-3.0.1.tar.xz 1332112 BLAKE2B 9479254de81c85a71dd3cbb20fa0f7e870f217c4f8ec618cb60bebf3791661fd93aba89c941cd8f5850cb2a51d48f5e3099e66b39d0e9a941aadb99e83000a70 SHA512 e220d1db7d01c4899d687b0c1eaf792a48ef3a2d356265fd89addfc89c23f41462967fc974b96d22714e0c812c70f83f919bc2b91803776025e0b907e0cd914d
DIST knot-3.0.2.tar.xz 1313864 BLAKE2B f2ff8c75a9b239b924af2eecc5e5afed27030fc9be6e112a4f61479f40247396c1d2905f58329fa84907c6ce796bc9a56d6f8e1cc83b737e15713844e0add32f SHA512 677de7a80688d4820d56c020af1bb1da97546f44a616e2d72d7e0301fca4a7ab682994cf66e8c37403e65ddb45ea3e0eb37b3304739c1239364115588c589699
102 changes: 102 additions & 0 deletions net-dns/knot/knot-3.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,102 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit systemd

DESCRIPTION="High-performance authoritative-only DNS server"
HOMEPAGE="https://www.knot-dns.cz/"
SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

KNOT_MODULES=(
"+cookies"
"+dnsproxy"
"dnstap"
"geoip"
"+noudp"
"+onlinesign"
"+queryacl"
"+rrl"
"+stats"
"+synthrecord"
"+whoami"
)
IUSE="doc caps +fastparser idn +libidn2 systemd +utils ${KNOT_MODULES[@]}"

RDEPEND="
acct-group/knot
acct-user/knot
dev-db/lmdb
dev-libs/libedit
dev-libs/userspace-rcu:=
dev-python/lmdb
net-libs/gnutls:=
caps? ( sys-libs/libcap-ng )
dnstap? (
dev-libs/fstrm
dev-libs/protobuf-c:=
)
geoip? ( dev-libs/libmaxminddb:= )
idn? (
!libidn2? ( net-dns/libidn:0= !net-dns/libidn2 )
libidn2? ( net-dns/libidn2:= )
)
systemd? ( sys-apps/systemd:= )
"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
doc? ( dev-python/sphinx )
"

S="${WORKDIR}/${P/_/-}"

src_configure() {
local u
local my_conf=(
--with-storage="${EPREFIX}/var/lib/${PN}"
--with-rundir="${EPREFIX}/var/run/${PN}"
$(use_enable fastparser)
$(use_enable dnstap)
$(use_enable doc documentation)
$(use_enable utils utilities)
--enable-systemd=$(usex systemd)
$(use_with idn libidn)
)

for u in "${KNOT_MODULES[@]#+}"; do
my_conf+=("$(use_with ${u} module-${u})")
done

econf "${my_conf[@]}"
}

src_compile() {
default

use doc && emake -C doc html
}

src_test() {
emake check
}

src_install() {
use doc && local HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )

default

rmdir "${D}/var/run/${PN}" "${D}/var/run/" || die

newinitd "${FILESDIR}/knot.init" knot
if use systemd; then
systemd_newunit "${FILESDIR}/knot-1.service" knot.service
fi

find "${D}" -name '*.la' -delete || die
}

0 comments on commit 9797457

Please sign in to comment.