Skip to content

Commit

Permalink
games-emulation/mgba: Bump to version 0.5.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.1
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Oct 6, 2016
1 parent 77de1f6 commit 986be1d
Show file tree
Hide file tree
Showing 2 changed files with 102 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/mgba/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mgba-0.5.0.tar.gz 5360529 SHA256 0efcd1e4f8c8d34d0384919ea19fa625fa2585d35d102c00b31930196c1f49bc SHA512 974b5cf3a0a112e7681d6117e09acaeffe44d72a0a74fddf9068b6c027a0c140d0f762fd97988d26c42e0a282806874870e2e2c1f1f277cb30a0c756f220f533 WHIRLPOOL ae8e975e38c7ab7370f4f20ea274d7e962f6556f0d12e107fc9ee5662e0b0d9680f9fb5358c319071d5b5d0e39c83786a90d41cb28c846cf9dd94597b0530626
DIST mgba-0.5.1.tar.gz 5342416 SHA256 d2173fbe69065ae1bd0abb323dcc3459d73c48ddc3d6934ef216cc50d1a0835d SHA512 a4c982028036d8bfb26053219421bcbfecd907cde102f5087076082dcf8f3c7d48aee0b22c22e7449708c3ad9886c3978556dba21cbfba46168ff5495ddd8354 WHIRLPOOL a079b7540f6692e006a1cc8d32e85182389758ee75167d1bc46416a91d78496cc5f86cabea57a65fcdf669affe5376f6a2f1c2e39b6a102cb4f8dca26612c82a
101 changes: 101 additions & 0 deletions games-emulation/mgba/mgba-0.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,101 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit fdo-mime gnome2-utils cmake-utils

DESCRIPTION="A new Game Boy Advance emulator written in C."
HOMEPAGE="https://mgba.io"
SRC_URI="https://github.com/${PN}-emu/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="ffmpeg imagemagick opengl qt5 +sdl"
REQUIRED_USE="|| ( qt5 sdl )
qt5? ( opengl )"

RDEPEND="
media-libs/libpng:0=
sys-libs/zlib[minizip]
ffmpeg? ( virtual/ffmpeg )
imagemagick? ( media-gfx/imagemagick:= )
opengl? ( virtual/opengl )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtmultimedia:5
dev-qt/qtwidgets:5
opengl? ( dev-qt/qtopengl:5 )
)
sdl? ( media-libs/libsdl2[X,sound,joystick,video,opengl?] )"
DEPEND="${RDEPEND}
>=dev-util/cmake-3.2.2"

src_prepare() {
default

# Get rid of any bundled stuff we don't want
for pkg in libpng lzma zlib ; do
rm -r "${S}"/src/third-party/${pkg} || die
done
}

src_configure() {
local mycmakeargs=(
-DBUILD_GL="$(usex opengl)"
-DBUILD_QT="$(usex qt5)"
-DBUILD_SDL="$(usex sdl)"
-DUSE_FFMPEG="$(usex ffmpeg)"
-DUSE_MAGICK="$(usex imagemagick)"
-DUSE_EPOXY=OFF
-DUSE_LIBZIP=OFF
-DUSE_LZMA=OFF
-DUSE_MINIZIP=ON
-DM_CORE_GB=ON
)
cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
if use qt5 ; then
for size in 16 24 32 48 64 96 128 256; do
newicon -s ${size} res/${PN}-${size}.png ${PN}.png
done
doman doc/${PN}-qt.6
domenu res/${PN}-qt.desktop
dobin ../${P}_build/qt/${PN}-qt
fi
if use sdl ; then
doman doc/${PN}.6
newbin ../${P}_build/sdl/${PN} ${PN}-sdl
fi

dolib.so ../${P}_build/lib${PN}.so*
}

pkg_preinst() {
if use qt5 ; then
gnome2_icon_savelist
fi
}

pkg_postinst() {
if use qt5 ; then
fdo-mime_desktop_database_update
gnome2_icon_cache_update
fi
}

pkg_postrm() {
if use qt5 ; then
fdo-mime_desktop_database_update
gnome2_icon_cache_update
fi
}

0 comments on commit 986be1d

Please sign in to comment.