Skip to content

Commit

Permalink
gui-apps/wf-shell: version bump to 0.6.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.8, Repoman-3.0.2
Signed-off-by: Aisha Tammy <[email protected]>
Closes: gentoo#18218
Signed-off-by: Aaron Bauman <[email protected]>
  • Loading branch information
epsilon-0 authored and FuzzyGophers committed Nov 13, 2020
1 parent aea321d commit 9896ade
Show file tree
Hide file tree
Showing 3 changed files with 52 additions and 6 deletions.
1 change: 1 addition & 0 deletions gui-apps/wf-shell/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST wf-shell-0.5.0.tar.xz 8998296 BLAKE2B c32232fc08292b15a0048d11d0f179a82fd21b3179223d898057ac95b42ac35ec063467f67c0f1261857c3b643edc4367112a05bb63f002788b64ed86559addd SHA512 d0029746ea10625bb47381a7ed74aadb8aa3823f83f751b539eefd49da5aa1643a2d16c55fe23d30bd71528ad5c1ea8d389909fe8cc1026746b3b76aa5dabd2b
DIST wf-shell-0.6.1.tar.xz 9014596 BLAKE2B 5256ceb8dc2b3dd4cf5d4503595c46b72bcde1dd4804a5871e225cee5b028ac69b02618d9c348fca4e21f2fd81b2be51fb0122126dd200dcdaeac894ec902c21 SHA512 d710cf703f5671bba01d056c7733724f90e6510a50e45a1a30cacde33a689c065335d802a3fd556cf9f8f0f420266ed2a8616706ecf5a68dcdf45a79876a4bcf
44 changes: 44 additions & 0 deletions gui-apps/wf-shell/wf-shell-0.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="A compiz like 3D wayland compositor"
HOMEPAGE="https://github.com/WayfireWM/wf-shell"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
else
SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi

LICENSE="MIT"
SLOT="0"
IUSE="+pulseaudio"

DEPEND="
dev-cpp/gtkmm:3.0=[wayland]
dev-libs/gobject-introspection
gui-libs/gtk-layer-shell
>=gui-wm/wayfire-${PV%.*}
pulseaudio? ( media-sound/pulseaudio )
"
RDEPEND="${DEPEND}
gui-apps/wayland-logout
"
BDEPEND="
dev-libs/wayland-protocols
virtual/pkgconfig
"

src_configure () {
local emesonargs=(
"$(meson_feature pulseaudio pulse)"
-Dwayland-logout=false
)
meson_src_configure
}
13 changes: 7 additions & 6 deletions gui-apps/wf-shell/wf-shell-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -12,7 +12,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
else
SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi

Expand All @@ -23,13 +23,13 @@ IUSE="+pulseaudio"
DEPEND="
dev-cpp/gtkmm:3.0=[wayland]
dev-libs/gobject-introspection
>=gui-libs/gtk-layer-shell-0.1
>=gui-wm/wayfire-${PV}
gui-libs/gtk-layer-shell
>=gui-wm/wayfire-${PV%.*}
pulseaudio? ( media-sound/pulseaudio )
"

RDEPEND="${DEPEND}"

RDEPEND="${DEPEND}
gui-apps/wayland-logout
"
BDEPEND="
dev-libs/wayland-protocols
virtual/pkgconfig
Expand All @@ -38,6 +38,7 @@ BDEPEND="
src_configure () {
local emesonargs=(
"$(meson_feature pulseaudio pulse)"
-Dwayland-logout=false
)
meson_src_configure
}

0 comments on commit 9896ade

Please sign in to comment.