Skip to content

Commit

Permalink
dev-haskell/tasty: tweak against unbounded-delays-0.1.1.0
Browse files Browse the repository at this point in the history
The patch fixes the following build failure:

```
Test/Tasty/Run.hs:80:6: error:
    Ambiguous occurrence ‘Timeout’
    It could refer to either ‘Control.Concurrent.Timeout.Timeout’,
                             imported from ‘Control.Concurrent.Timeout’ at Test/Tasty/Run.hs:18:1-33
                          or ‘Test.Tasty.Options.Core.Timeout’,
                             imported from ‘Test.Tasty.Options.Core’ at Test/Tasty/Run.hs:29:1-30
                             (and originally defined
                                at Test/Tasty/Options/Core.hs:(54,1)-(60,27))
```

Reported-by: Toralf Förster
Closes: https://bugs.gentoo.org/702906
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Dec 15, 2019
1 parent 04ed1a3 commit 98e9e54
Show file tree
Hide file tree
Showing 2 changed files with 28 additions and 0 deletions.
26 changes: 26 additions & 0 deletions dev-haskell/tasty/files/tasty-0.11.0.4-unbounded-delays.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
https://bugs.gentoo.org/702906

From 74e87fff6a4a830dc64d59f4baa1a5f6759c007c Mon Sep 17 00:00:00 2001
From: Roman Cheplyaka <[email protected]>
Date: Fri, 5 May 2017 08:54:28 +0300
Subject: [PATCH] Fix compatibility with the latest unbounded-delays

Fixes #166
---
core/Test/Tasty/Run.hs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

--- a/Test/Tasty/Run.hs
+++ b/Test/Tasty/Run.hs
@@ -15,7 +15,7 @@ import Control.Monad.State
import Control.Monad.Writer
import Control.Monad.Reader
import Control.Concurrent.STM
-import Control.Concurrent.Timeout
+import Control.Concurrent.Timeout (timeout)
import Control.Concurrent.Async
import Control.Exception as E
import Control.Applicative
--
2.24.1

2 changes: 2 additions & 0 deletions dev-haskell/tasty/tasty-0.11.0.4.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -17,6 +17,8 @@ SLOT="0/${PV}"
KEYWORDS="amd64 x86"
IUSE=""

PATCHES=("${FILESDIR}"/${P}-unbounded-delays.patch)

RDEPEND=">=dev-haskell/ansi-terminal-0.6.2:=[profile?]
>=dev-haskell/async-2.0:=[profile?]
>=dev-haskell/clock-0.4.4.0:=[profile?]
Expand Down

0 comments on commit 98e9e54

Please sign in to comment.