Skip to content

Commit

Permalink
media-libs/ptex: 2.3.2 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed May 21, 2019
1 parent fd614c5 commit 9906825
Show file tree
Hide file tree
Showing 3 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/ptex/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ptex-2.1.28.tar.gz 305327 BLAKE2B 4a91b08ae326e8ed8d420022c693ea60cb21908380b8c49a7672771686f9dd2ef05151b7d43755bc63ab6624db772c2b53d1ffdcdea9c1dff7627cc3fe0f3b15 SHA512 ddce3c79f14d196e550c1e8a5b371482f88190cd667a2e2aa84601de1639f7cabb8571c1b3a49b48df46ce550d27088a00a67b1403c3bfec2ed73437c3dca3e8
DIST ptex-2.3.0.tar.gz 306462 BLAKE2B 790e3623ce6ebae2dfd8884d8e19e62395c54432289d88bdcf3a01c8ae1ef752ca88869357ac1e4657d59f1ca73d311a3fb9a08efe4e145ca259eff93d8a3b6a SHA512 2d9d320e4205236a4eff05ec3c67d085624809ebefa89fa3b943d18a8b2b6a5f61c022a4cc4363a7c6ceccfb9eac4f8738dff2e90a3355814f2c4ff096c09992
DIST ptex-2.3.2.tar.gz 308550 BLAKE2B 7b3145dbf9d2c13140c3f20ed606ee911deed3c38fd30adfbb01b58c3af5794dbd4e0fa1fbab6e8ae83556a0ffec725bf077271abf752f1271ed721ca200a1ff SHA512 dbc557dc5e1761204ee3483af9bf4ff1504cbd7955e0405dc27a51f7182e2445e41db086b2792c2491aa2cbaddc74e523170a4b3d25e44d332123d5b7081f4b9
22 changes: 22 additions & 0 deletions media-libs/ptex/files/ptex-2.3.2-cxx11.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
--- a/CMakeLists.txt 2019-03-08 18:39:47.000000000 +0100
+++ b/CMakeLists.txt 2019-05-21 23:20:50.964082298 +0200
@@ -5,19 +5,6 @@
option(PTEX_BUILD_SHARED_LIBS "Enable building Ptex shared libraries" ON)
option(PRMAN_15_COMPATIBLE_PTEX "Enable PRMan 15 compatibility" OFF)

-if (DEFINED ENV{CXXFLAGS_STD})
- if ($ENV{CXXFLAGS_STD} STREQUAL "c++17")
- set(CMAKE_CXX_STANDARD 17)
- elseif ($ENV{CXXFLAGS_STD} STREQUAL "c++14")
- set(CMAKE_CXX_STANDARD 14)
- elseif ($ENV{CXXFLAGS_STD} STREQUAL "c++11")
- set(CMAKE_CXX_STANDARD 11)
- else ()
- set(CMAKE_CXX_STANDARD 98)
- endif ()
-else ()
- set(CMAKE_CXX_STANDARD 98)
-endif ()
set(CMAKE_CXX_EXTENSIONS OFF)
set(CMAKE_FIND_PACKAGE_RESOLVE_SYMLINKS ON)
set(CMAKE_INSTALL_MESSAGE LAZY) # Silence "Up-to-date:" install messages
39 changes: 39 additions & 0 deletions media-libs/ptex/ptex-2.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils

DESCRIPTION="Per-Face Texture Mapping for Production Rendering"
HOMEPAGE="http://ptex.us/"
SRC_URI="https://github.com/wdas/ptex/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs"

BDEPEND="app-doc/doxygen"
RDEPEND="sys-libs/zlib"
DEPEND="${RDEPEND}"

RESTRICT="test"

PATCHES=( "${FILESDIR}/${P}-cxx11.patch" )

src_prepare() {
# https://github.com/wdas/ptex/issues/41
cat <<-EOF > version || die
${PV}
EOF
cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/html"
-DPTEX_BUILD_STATIC_LIBS=$(usex static-libs)
)
cmake-utils_src_configure
}

0 comments on commit 9906825

Please sign in to comment.