Skip to content

Commit

Permalink
games-arcade/xscavenger: Stop using games.eclass
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
pacho2 committed Apr 25, 2018
1 parent f28cc16 commit 9926689
Showing 1 changed file with 48 additions and 0 deletions.
48 changes: 48 additions & 0 deletions games-arcade/xscavenger/xscavenger-1.4.4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit desktop epatch toolchain-funcs

DESCRIPTION="Lode-Runner-like arcade game"
HOMEPAGE="http://www.xdr.com/dash/scavenger.html"
SRC_URI="http://www.xdr.com/dash/${P}.tgz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="x11-libs/libXext"
DEPEND="${RDEPEND}
x11-misc/imake
"

S="${WORKDIR}/${P}/src"

src_prepare() {
default
epatch "${FILESDIR}/${PV}-gentoo.patch"
sed -i \
-e "s:GENTOO_DATADIR:/usr/share:" \
-e "s:GENTOO_BINDIR:/usr/bin:" \
Imakefile \
|| die
}

src_configure() {
xmkmf || die
}

src_compile() {
emake \
CC="$(tc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \
EXTRA_LDOPTIONS="${LDFLAGS}"
}

src_install() {
emake DESTDIR="${D}" install
dodoc ../{CREDITS,DOC,README,TODO,changelog}
make_desktop_entry scavenger "XScavenger"
}

0 comments on commit 9926689

Please sign in to comment.