forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
* Bump to EAPI8 * Fix HOMEPAGE (https:// is not supported) Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Thomas Beierlein <[email protected]>
- Loading branch information
Showing
2 changed files
with
95 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST hamlib-4.2.tar.gz 2311775 BLAKE2B 4fe8d3e6d489369aede1a4cd59f01be44a7787ca71c21c5b92d436666c67de68013f488834d0f57238e6a947c24cd5b4c6c667397dec30392f1cccd695df252e SHA512 08ccf4e592fbae938ae1aaa5afede7e2e6ec7d23b449a65b00e093502f4aeb36930624f055d9802349f77df9dd2b7b983aa44d83f8c62a6de5789e7df627f804 | ||
DIST hamlib-4.3.1.tar.gz 2356944 BLAKE2B c803d253c867303cbde98b6f2e10f610aac111b7bd81fd343e1396cb86384b1c26942e5ccb8e395e073f9aa3d48e6f9edc1b64da14b2ec5ca09f98fbd3dee667 SHA512 8dee4676a19de7ac1ef733a4285b76e918f11aad6594d0557d36df295faf04c615e0993edb2f9ed5e7aea718c184603fec831caf28b75026c705f0b2e4b9eca7 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,94 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
PYTHON_COMPAT=( python3_{7..10} ) | ||
MY_P=${P/_rc2/~rc2} | ||
|
||
inherit autotools python-single-r1 | ||
|
||
DESCRIPTION="Ham radio backend rig control libraries" | ||
HOMEPAGE="http://www.hamlib.org" | ||
SRC_URI="mirror://sourceforge/hamlib/${MY_P}.tar.gz" | ||
|
||
LICENSE="LGPL-2 GPL-2" | ||
SLOT="0/4.2" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="doc perl python tcl" | ||
|
||
RESTRICT="test" | ||
|
||
RDEPEND=" | ||
=virtual/libusb-0* | ||
dev-libs/libxml2 | ||
sys-libs/readline:0= | ||
perl? ( dev-lang/perl ) | ||
python? ( ${PYTHON_DEPS} ) | ||
tcl? ( dev-lang/tcl:0= )" | ||
|
||
DEPEND=" ${RDEPEND} | ||
virtual/pkgconfig | ||
dev-lang/swig | ||
>=sys-devel/libtool-2.2 | ||
doc? ( app-doc/doxygen )" | ||
|
||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer) | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
pkg_setup() { | ||
use python && python-single-r1_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
# fix hardcoded libdir paths | ||
sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \ | ||
-e "s#fix}/include#fix}/include/hamlib#" \ | ||
hamlib.pc.in || die "sed failed" | ||
|
||
# Correct install target to whatever INSTALLDIRS says and use vendor | ||
# installdirs everywhere (bug #611550) | ||
sed -i -e "s#install_site#install#" \ | ||
-e 's#MAKEFILE="Hamlib-pl.mk"#MAKEFILE="Hamlib-pl.mk" INSTALLDIRS=vendor#' \ | ||
bindings/Makefile.am || die "sed failed patching for perl" | ||
|
||
# make building of documentation compatible with autotools-utils | ||
sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed" | ||
|
||
eautoreconf | ||
|
||
eapply_user | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
--libdir=/usr/$(get_libdir)/hamlib \ | ||
--disable-static \ | ||
--with-xml-support \ | ||
$(use_with perl perl-binding) \ | ||
$(use_with python python-binding) \ | ||
$(use_with tcl tcl-binding) | ||
} | ||
|
||
src_compile() { | ||
emake | ||
use doc && emake html | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" install | ||
|
||
use python && python_optimize | ||
|
||
use doc && HTML_DOCS=( doc/html/ ) | ||
einstalldocs | ||
|
||
insinto /usr/$(get_libdir)/pkgconfig | ||
doins hamlib.pc | ||
|
||
echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib | ||
doenvd "${T}"/73hamlib | ||
} |