Skip to content

Commit

Permalink
games-rpg/wastesedge: update to 0.3.8
Browse files Browse the repository at this point in the history
Migrated to python3, minor fixes for EAPI7.

Closes: https://bugs.gentoo.org/735354
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Signed-off-by: Azamat H. Hackimov <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
winterheart authored and juippis committed Oct 2, 2020
1 parent c91384e commit 9988be2
Show file tree
Hide file tree
Showing 3 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-rpg/wastesedge/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST wastesedge-src-0.3.5.tar.gz 10749912 BLAKE2B ec4cd1135cd09c92937c8749905872b635e72575662bb7c1e188281e47ec0a285045aced378659fed20942c4bc7e67f11fa95e1cf0fe220c0be0f3b6527aa754 SHA512 d4c77eb1bde2c28002e4f56a6bfa5f816ea53de7061b5e60635f15c670ff45c3a18e3316b92007f74033a62538503f14b67e1175cf22c718c22ca1021dc7af3b
DIST wastesedge-src-0.3.8.tar.gz 20779629 BLAKE2B 40a63298ea9b704407fcac244f22a3e26190fec37cb0dae0e18e55478d866a215a6be6e1bd08ef2d303894aca2edd09e7b299ae9c2da21d999f47c6d799fde83 SHA512 410e01d803b6ff72c4c0d8f035c5e3228c2311bc200359ecb748be63474ae0afb8609cc9daed940670d02190fa3c047ea2a2cd116b7680398cdcc7523a64c386
35 changes: 35 additions & 0 deletions games-rpg/wastesedge/files/wastesedge-0.3.8_version-handling.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From b3987b74cc6ff89187b95c692a4aacc13db98564 Mon Sep 17 00:00:00 2001
From: "Azamat H. Hackimov" <[email protected]>
Date: Wed, 9 Sep 2020 20:01:41 +0300
Subject: [PATCH] Rework adonthell version handling

---
configure.ac | 11 +++--------
1 file changed, 3 insertions(+), 8 deletions(-)

diff --git a/configure.ac b/configure.ac
index 76d87bd..fff8268 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,15 +46,10 @@ fi

dnl Checking for the proper version
AC_MSG_CHECKING(for Adonthell's version)
-$adonthell_binary -v &> adonthell.ver

-changequote(<<, >>)
-adonthell_major_ver=`sed 's/\([0-9]*\)\.[0-9]*\.[0-9]*/\1/p; d' adonthell.ver`
-adonthell_minor_ver=`sed 's/[0-9]*\.\([0-9]*\)\.[0-9]*/\1/p; d' adonthell.ver`
-adonthell_micro_ver=`sed 's/[0-9]*\.[0-9]*\.\([0-9]*\)/\1/p; d' adonthell.ver`
-changequote([, ])
-
-rm -f adonthell.ver
+adonthell_major_ver=$($adonthell_binary -v | cut -d'.' -f1)
+adonthell_minor_ver=$($adonthell_binary -v | cut -d'.' -f2)
+adonthell_micro_ver=$($adonthell_binary -v | cut -d'.' -f3)

adonthellver="$adonthell_major_ver.$adonthell_minor_ver.$adonthell_micro_ver"

--
2.26.2

37 changes: 37 additions & 0 deletions games-rpg/wastesedge/wastesedge-0.3.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )

inherit autotools python-single-r1

DESCRIPTION="Role playing game to showcase the adonthell engine"
HOMEPAGE="http://adonthell.nongnu.org/download/"
SRC_URI="https://savannah.nongnu.org/download/adonthell/${PN}-src-${PV}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="nls"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="${PYTHON_DEPS}
>=games-rpg/adonthell-0.3.8[${PYTHON_SINGLE_USEDEP}]
nls? ( virtual/libintl )"
BDEPEND="nls? ( sys-devel/gettext )"

PATCHES=( "${FILESDIR}/${P}_version-handling.patch" )
DOCS=( AUTHORS ChangeLog NEWS PLAYING README )

src_prepare() {
default
eautoreconf
}

src_configure() {
econf \
$(use_enable nls) \
--with-adonthell-binary="/usr/bin/adonthell"
}

0 comments on commit 9988be2

Please sign in to comment.