Skip to content

Commit

Permalink
dev-perl/XML-LibXML: Bump to version 2.13.200
Browse files Browse the repository at this point in the history
- Cleanup more author tests

Upstream:
- Fix test failures w/ libxml2-2.9.6
- Fix bug in Node::replaceChild()

Bug: https://bugs.gentoo.org/635318
Bug: https://bugs.gentoo.org/630934
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
kentfredric committed Mar 24, 2018
1 parent ee031ad commit 99e5660
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-perl/XML-LibXML/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST XML-LibXML-2.0128.tar.gz 466334 BLAKE2B 7b7de24ed9cbafde79061e70247ed715e6009acf9d0ef75cc08d838d51c7b736ee7f4e57f069b1112c171ac398c28745082760f8e1d892834ab0c811c8a09e57 SHA512 c388570d0a140f3b92ab9922d9c917fba791e804b160822eeff91923891059ba189ad3743f2ffd13f7f4c92a3e8db1ee5fae588007d3fcf50251d9803e8e261b
DIST XML-LibXML-2.0129.tar.gz 468838 BLAKE2B dce86bff8d4fcc87d5fc1e957ec7f89586ba8b34fd826680267995912ac54b1460850a22ea572a55d441fdb5719f8fbe6070b0d64f39f3e4fac9a5252ffd4396 SHA512 f17c61052975ecc188c285ee93dbb07926c880a28e49afdd5af0c7c997e8b12be72412d0964391f1232f853935ee0ff2838cd5d62f8f3b4f52c341904069ccea
DIST XML-LibXML-2.0132.tar.gz 469983 BLAKE2B 66002c35adc1156af76f16af2a1b4617ef25470cb434ee73dd9242fdc37a20d5d417ce5003ca202f69de08e053705129c083e65d483ae7e85375ae2ad6cbedc5 SHA512 3df1cb67ea955133492f2b6f8def2b28079c59e99170a31820aca69ea81686c4b67171509f1b311faab9389d200c4a24942b3950d7c0730ff1233a009b398fce
69 changes: 69 additions & 0 deletions dev-perl/XML-LibXML/XML-LibXML-2.13.200.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DIST_AUTHOR=SHLOMIF
DIST_VERSION=2.0132
DIST_EXAMPLES=("example/*")
inherit perl-module

DESCRIPTION="Perl binding for libxml2"

SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="test minimal"

RDEPEND="
>=dev-perl/XML-SAX-0.120.0
>=dev-libs/libxml2-2.6.21
dev-perl/XML-SAX-Base
>=dev-perl/XML-NamespaceSupport-1.70.0
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
!minimal? (
dev-perl/Test-LeakTrace
)
)
"

PATCHES=(
"${FILESDIR}/${PN}-2.12.800-disable-expanding.patch"
)

PERL_RM_FILES=(
"t/cpan-changes.t" "t/pod-files-presence.t" "t/pod.t"
"t/release-kwalitee.t" "t/style-trailing-space.t"
)

src_compile() {
export SKIP_SAX_INSTALL=1
perl-module_src_compile
}

pkg_postinst() {
pkg_update_parser add XML::LibXML::SAX::Parser
pkg_update_parser add XML::LibXML::SAX
}

pkg_postrm() {
pkg_update_parser remove XML::LibXML::SAX::Parser
pkg_update_parser remove XML::LibXML::SAX
}

pkg_update_parser() {
# pkg_update_parser [add|remove] $parser_module
local action=$1
local parser_module=$2

if [[ "$ROOT" = "/" ]] ; then
einfo "Update Parser: $1 $2"
perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
|| ewarn "Update Parser: $1 $2 failed"
else
elog "To $1 $2 run:"
elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
fi
}

0 comments on commit 99e5660

Please sign in to comment.