Skip to content

Commit

Permalink
net-analyzer/cacti: Version 1.2.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Aug 12, 2019
1 parent 7a7a627 commit 9a44116
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-analyzer/cacti/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST cacti-1.1.38.tar.gz 9081347 BLAKE2B 9f64bc7cd33187c4c744e1473409ea8998cd953c6fd047c66af6ff07d288678cbd944d2e70d0fc3838a42c7f7a9dbf7b094963391791a46bc50c3ed65ed4251f SHA512 1f91156416a9988fa149f9b8fc9fc7df904e4cf6d9a19a62d06c7de1ded99ddaec2f5b5f1a21b0effc4dee7b9c1d1911ca5aaa6113b57edc7e2f42b7969343b5
DIST cacti-1.2.2.tar.gz 23800723 BLAKE2B 3608edd60d796dcd8c875f2611c268605813d9f4102ecac99dd71d1b7a904f7bb74031d1c5692d0af7964af9e1a13fb46a88d98bbb6961bde0696b339fe84505 SHA512 4a41aff20f06ad56f4723e52084d1a09e3b3eb017e8f1c957f700e4e2f9b12e8f0e599cb56611241c6fcc59bbd6bf957e948631f3beca72e2a7fdadacc473c65
DIST cacti-1.2.5.tar.gz 24677665 BLAKE2B 098a855c9eda7c6eca255a96be0d6abe016be00ffd985ce356773e8af4114ecdca4753e1b288a697c8defbbe481a9244eecf553f228518e1c223b582e0974eb7 SHA512 991847ded6045c8c6111c58c5f8687f2497183a545158924bba92ee5d0b7de3e658ddbfce6f59c651fa29118aedb271a438c5668a3db4b93f97f82fe721f0a32
48 changes: 48 additions & 0 deletions net-analyzer/cacti/cacti-1.2.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit eutils webapp

# Support for _p* in version.
MY_P=${P/_p*/}

DESCRIPTION="Cacti is a complete frontend to rrdtool"
HOMEPAGE="https://www.cacti.net/"
SRC_URI="https://www.cacti.net/downloads/${MY_P}.tar.gz"

LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="snmp doc"

need_httpd

RDEPEND="
dev-lang/php[cli,mysql,pdo,session,sockets,xml]
dev-php/adodb
net-analyzer/rrdtool[graph]
virtual/cron
snmp? ( >=net-analyzer/net-snmp-5.2.0 )
"

src_compile() { :; }

src_install() {
dodoc CHANGELOG
dodoc -r docs
mv docs .. || die

webapp_src_preinst

edos2unix `find -type f -name '*.php'`

dodir ${MY_HTDOCSDIR}
cp -r . "${D}"${MY_HTDOCSDIR}

webapp_serverowned ${MY_HTDOCSDIR}/rra
webapp_serverowned ${MY_HTDOCSDIR}/log
webapp_configfile ${MY_HTDOCSDIR}/include/config.php
webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt

webapp_src_install
}

0 comments on commit 9a44116

Please sign in to comment.