Skip to content

Commit

Permalink
app-portage/deltup: respect user's LDFLAGS, use CX, not CC
Browse files Browse the repository at this point in the history
While at it dropped use of unknown command:
    epatch_user: command not found

Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
Sergei Trofimovich committed Jul 20, 2017
1 parent 14701b1 commit 9a8ce34
Show file tree
Hide file tree
Showing 3 changed files with 37 additions and 5 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -26,13 +26,13 @@ DEPEND="
RDEPEND="${DEPEND}
|| ( dev-util/bdelta =dev-util/xdelta-1* )"

src_prepare () {
default
epatch_user
}
PATCHES=(
"${FILESDIR}"/${PN}-0.4.6-ldflags.patch
"${FILESDIR}"/${PN}-0.4.6-cxx.patch
)

src_compile () {
emake CC=$(tc-getCXX)
emake CXX=$(tc-getCXX)
}

src_install () {
Expand Down
23 changes: 23 additions & 0 deletions app-portage/deltup/files/deltup-0.4.6-cxx.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
diff --git a/Makefile b/Makefile
index 6a3aa95..a591a6f 100644
--- a/Makefile
+++ b/Makefile
@@ -7,3 +7,3 @@ CC = g++
objfiles=bpatch.o archfunc.o file.o system.o tmpstore.o deltup.o
-libs=-lstdc++ -lz -lbz2 -lcrypto #-lssl
+libs=-lz -lbz2 -lcrypto #-lssl

@@ -12,3 +12,3 @@ libs=-lstdc++ -lz -lbz2 -lcrypto #-lssl
%.o : %.cpp
- ${CC} -c $< -o $@ ${CXXFLAGS} #-g #-Wall -pedantic
+ ${CXX} -c $< -o $@ ${CXXFLAGS} #-g #-Wall -pedantic

@@ -17,6 +17,6 @@ all: deltup
depend:
- gcc -MM *.cpp > .depend
+ ${CXX} -MM *.cpp > .depend

deltup: $(objfiles)
- ${CC} $(objfiles) ${LDFLAGS} -o deltup $(libs)
+ ${CXX} $(objfiles) ${LDFLAGS} -o deltup $(libs)

9 changes: 9 additions & 0 deletions app-portage/deltup/files/deltup-0.4.6-ldflags.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,9 @@
diff --git a/Makefile b/Makefile
index 6a3aa95..6e7c5cf 100644
--- a/Makefile
+++ b/Makefile
@@ -20,3 +20,3 @@ depend:
deltup: $(objfiles)
- ${CC} $(objfiles) ${CXXFLAGS} -o deltup $(libs)
+ ${CC} $(objfiles) ${LDFLAGS} -o deltup $(libs)

0 comments on commit 9a8ce34

Please sign in to comment.