Skip to content

Commit

Permalink
dev-java/joda-convert: bump to 2.2.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Volkmar W. Pogatzki <[email protected]>
Closes: gentoo#23429
Signed-off-by: Miroslav Šulc <[email protected]>
  • Loading branch information
vaukai authored and fordfrog committed Dec 21, 2021
1 parent 5ba3393 commit 9afc102
Show file tree
Hide file tree
Showing 3 changed files with 74 additions and 1 deletion.
1 change: 1 addition & 0 deletions dev-java/joda-convert/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST joda-convert-1.3.1-dist.tar.gz 131288 BLAKE2B 0b7b6cebb7e13e89d838ec10c4edd54b52bf3449b3003cd41ea2628719b8ea52bc00a8681a96fad0de79b4acd56fc4a8d4a31d558841fa268d9ffbeb97ca1ed0 SHA512 ee3f7264e9ee445dd8cf088c862809faceb012d317c4974d2312e1ce9b580193096259978a79cdefc2217818600ff38569348625986e19bdb753edb03ba58451
DIST joda-convert-2.2.2.tar.gz 65476 BLAKE2B 9ef8e3b172d31f4e3b748ba5aae807b1d344c3b6bedeb0bf0b84b93009171495f271d03cd9f7b29147a256ddd1081b3fc9640c1df6b45425080ce1d44e2c0f37 SHA512 9660491373d5f7d415ab47cec7164922fc8901803e759bbf8cf7d0cc58040c2c8b245271f33d641a563ffb25b8e42f8197e297da7d1fe68a5c50ebb61536f3ae
71 changes: 71 additions & 0 deletions dev-java/joda-convert/joda-convert-2.2.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Skeleton command:
# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/JodaOrg/joda-convert/archive/refs/tags/v2.2.2.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild joda-convert-2.2.2.ebuild

EAPI=8

JAVA_PKG_IUSE="doc source test"
MAVEN_ID="org.joda:joda-convert:2.2.2"
JAVA_TESTING_FRAMEWORKS="junit-4"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Library to convert Objects to and from String"
HOMEPAGE="https://www.joda.org/joda-convert/"
SRC_URI="https://github.com/JodaOrg/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"

# Compile dependencies
# POM: pom.xml
# test? com.google.guava:guava:31.0.1-jre -> !!!suitable-mavenVersion-not-found!!!
# test? junit:junit:4.13.2 -> >=dev-java/junit-4.13.2:4

DEPEND="
>=virtual/jdk-1.8:*
test? (
dev-java/guava:20
)
"

RDEPEND="
>=virtual/jre-1.8:*
"

DOCS=( {LICENSE,NOTICE,RELEASE-NOTES}.txt README.md )

S="${WORKDIR}/${P}"

JAVA_SRC_DIR="src/main/java"
# JAVA_RESOURCE_DIRS=""

JAVA_TEST_GENTOO_CLASSPATH="guava-20,junit-4"
JAVA_TEST_SRC_DIR="src/test/java"
JAVA_TEST_RESOURCE_DIRS="src/test/resources"

JAVA_TEST_EXCLUDES=(
# Upstream: Tests run: 186, Failures: 0, Errors: 0, Skipped: 0
# All following: No runnable methods
org.joda.convert.test1.Test1Class
org.joda.convert.test1.Test1Interface
org.joda.convert.test2.Test2Class
org.joda.convert.test2.Test2Factory
org.joda.convert.test2.Test2Interface
org.joda.convert.test3.Test3Class
org.joda.convert.test3.Test3Factory
org.joda.convert.test3.Test3Interface
org.joda.convert.test3.Test3SuperClass
org.joda.convert.test4.Test4Class
org.joda.convert.test4.Test4Factory
org.joda.convert.test4.Test4Interface
org.joda.convert.TestRenameHandlerBadInit
)

src_install() {
default # https://bugs.gentoo.org/789582
java-pkg-simple_src_install
}
3 changes: 2 additions & 1 deletion dev-java/joda-convert/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,7 @@
<name>Java</name>
</maintainer>
<upstream>
<remote-id type="sourceforge">joda-convert</remote-id>
<remote-id type="github">JodaOrg/joda-convert</remote-id>
<bugs-to>https://github.com/JodaOrg/joda-convert/issues</bugs-to>
</upstream>
</pkgmetadata>

0 comments on commit 9afc102

Please sign in to comment.